Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

When I plug in external usb driver I saw next prompt:

Error mounting: mount exited with exit code 1: helper failed with:
Unprivileged user can not mount NTFS block devices using the external FUSE
library. Either mount the volume as root, or rebuild NTFS-3G with integrated
FUSE support and make it setuid root. Please see more information at
http://tuxera.com/community/ntfs-3g-faq/#unprivileged

This is my current sudo fdisk -l:

nazar_art@nazar-desctop:~/Desktop/Big JAVA/bj4_code/ch24/time$ sudo fdisk -l

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders, total 312581808 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000e28b8

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048   310484991   155241472   83  Linux
/dev/sda2       310487038   312580095     1046529    5  Extended
/dev/sda5       310487040   312580095     1046528   82  Linux swap / Solaris

Disk /dev/sdb: 1015 MB, 1015808000 bytes
31 heads, 32 sectors/track, 2000 cylinders, total 1984000 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *          31     1983999      991984+   6  FAT16

Disk /dev/sdd: 7751 MB, 7751073792 bytes
255 heads, 63 sectors/track, 942 cylinders, total 15138816 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xc3072e18

   Device Boot      Start         End      Blocks   Id  System
/dev/sdd1   *          63    15138815     7569376+   7  HPFS/NTFS/exFAT

And gksudo gedit /etc/fstab:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc                                       /proc           proc  nodev,noexec,nosuid         0  0  
# / was on /dev/sda1 during installation
UUID=5f5d330f-d5f2-4157-9496-94f1dce2f181  /               ext4  errors=remount-ro           0  1  
# swap was on /dev/sda5 during installation
UUID=84747ef4-6f50-49bc-9df1-fcba364ba299  none            swap  sw                          0  0  

/dev/fd0                                   /media/floppy0  auto  rw,user,noauto,exec,utf8    0  0  
/dev/sdc1                                  /media/sdc1     auto  uid=1000,noauto,users,exec  0  0  
/dev/sdd1                                  /media/sdd1     auto  uid=1000,noauto,users,exec  0  0  
/dev/sdb1                                  /media/sdb1     auto  uid=1000,noauto,users,exec  0  0

Update: Checked if is installed ntfs-3g:

nazar_art@nazar-desctop:~$ dpkg -s ntfs-3g
Package: ntfs-3g
Status: install ok installed
Priority: optional
Section: otherosfs
Installed-Size: 1422
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Architecture: amd64
Version: 1:2012.1.15AR.1-1ubuntu1.2
Replaces: libntfs-3g75, ntfsprogs
Depends: debconf (>= 0.5) | debconf-2.0, libc6 (>= 2.14), libfuse2 (>= 2.8.1), libgcrypt11 (>= 1.4.5), libgnutls26 (>= 2.12.6.1-0), initramfs-tools (>= 0.99), initscripts (>= 2.88dsf-13.3)
Pre-Depends: multiarch-support, fuse
Conflicts: libntfs-3g75, ntfsprogs (<< 1:2011.10.9AR.1-3~)
Description: read/write NTFS driver for FUSE
 NTFS-3G uses FUSE (Filesystem in Userspace) to provide support for the NTFS
 filesystem used by Microsoft Windows. It can:
 .
  * create, remove, rename, or move files, directories, hard links, and streams;
  * read and write files, including streams, sparse files, and transparently
    compressed files;
  * handle special files like symbolic links, devices, and FIFOs;
  * provide standard management of file ownership and permissions, including
    POSIX ACLs.
 .
 This package also contains the tools previously available in the ntfsprogs
 package.
Homepage: http://www.tuxera.com/community/ntfs-3g-advanced/
Original-Maintainer: Daniel Baumann <daniel.baumann@progress-technologies.net>

Figuring out exactly usb drive through lsblk:

nazar_art@nazar-desctop:~$ lsblk
NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda      8:0    0 149.1G  0 disk 
├─sda1   8:1    0 148.1G  0 part /
├─sda2   8:2    0     1K  0 part 
└─sda5   8:5    0  1022M  0 part [SWAP]
sdb      8:16   1   7.2G  0 disk 
└─sdb1   8:17   1   7.2G  0 part 
sdc      8:32   1 968.8M  0 disk 
└─sdc1   8:33   1 968.8M  0 part /media/sdc1
sr0     11:0    1  1024M  0 rom

It's sdb1 - this external usb drive.

Tried again manually mount:

nazar_art@nazar-desctop:~$ sudo mount /media/sdb1
[sudo] password for nazar_art: 
The disk contains an unclean file system (0, 0).
The file system wasn't safely closed on Windows. Fixing.

Now all is visible.

- Why this happen?
- How to solve this issue?

share|improve this question
    
is ntfs-3g package installed on your system? –  mavillan Sep 5 '13 at 5:50
    
@mavillan I updated question –  nazar_art Sep 5 '13 at 6:45
    
Use the type field in /etc/fstab to specify an NTFS mount and make sure you have write permissions to /media: see wiki.archlinux.org/index.php/Ntfs –  jasonwryan Sep 5 '13 at 7:15

1 Answer 1

up vote 1 down vote accepted

The error is indicating a lack of permissions when attempting to mount the filesystem. I suspect the program that performs the mount on plugin is running under a non-root user (probably the user account used to login).

Even though fstab includes the users option, it appears that a part of the mount process still requires root access.

To fix, manually perform the mount as root. This should do the job:

sudo mount /media/sdd1

It should be possible to configure the system so that the program performing the mount runs as root, but that's not as simple as it sounds.

share|improve this answer
    
I did this and it's output - mount: special device /dev/sdd1 does not exist. Why can't it see this usb drive? –  nazar_art Sep 5 '13 at 6:38
    
It may be another issue. First I would check dmesg and see if it tells where the USB device driver is located. Today I was using /dev/ub/a/part1 for a USB device. There may just be no /dev/sdd1 there, or that device may not have the right major/minor number for the USB memory stick, even though some tools are showing that device node. –  ash Sep 5 '13 at 6:45
    
here is output from dmesg. I couldn’t figure out location. Can you help me to fix this trouble? –  nazar_art Sep 5 '13 at 6:52
    
Is this the usb stick? usb 1-2: Product: RiDATA USB Device. If so, the kernel is seeing it, so the trick is to find the device node that matches. Let me see if I can find info on usb dev nodes. –  ash Sep 5 '13 at 7:04
    
The device is currently connected, right? Can you try unplugging it and plugging it back in, then see the tail of the dmesg output again? Right now, I'm having a hard time figuring out how you can find the right device node. It usually shows up in the dmesg output when the device connects. –  ash Sep 5 '13 at 7:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.