Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

My system is Gentoo amd64, up to date.

[I] dev-libs/boost
 Available versions:  1.49.0-r2 (~)1.52.0-r6(0/1.52) (~)1.53.0(0/1.53) [M](~)1.54.0(0/1.54) {debug doc icu mpi +nls python static-libs +threads tools PYTHON_TARGETS="python2_5 python2_6 python2_7 python3_1 python3_2 python3_3"}
 Installed versions:  1.53.0(10:17:32 PM 08/19/2013)(icu nls python threads -debug -doc -mpi -static-libs -tools PYTHON_TARGETS="python2_7 python3_2 -python2_5 -python2_6 -python3_1 -python3_3")
 Homepage:            http://www.boost.org/
 Description:         Boost Libraries for C++

My boost is already compiled with threads USE flag.

But I still got this error when compiling Hugin.

../hugin_base/libhuginbase.so.0.0: undefined reference to `boost::thread::join()'
../hugin_base/libhuginbase.so.0.0: undefined reference to  boost::thread::start_thread()'
collect2: error: ld returned 1 exit status

Some people suggests downgrade boost to 1.47...but it is no longer in the portage.

share|improve this question
1  
This seems dated but might be helpful to you: forums.gentoo.org/viewtopic-t-899582-start-0.html –  slm Sep 1 '13 at 1:10
    
Thanks @slm, that's exactly where I got the idea to downgrade boost. And because that was dated, the downgrade option is no longer viable :( –  davidshen84 Sep 1 '13 at 3:07
    
Builds ok for me with boost-1.49.0-r2. –  Mat Sep 1 '13 at 8:38
    
Oh, that's good news. But the problem is that I cannot downgrade boost at all. The boost 1.53 depends on glibc-2.17, and boost-1.49 depends on glibc-2.15. And downgrade glibc is prohibited. –  davidshen84 Sep 1 '13 at 8:59
    
I've just upgraded boost to 1.53 and my glibc is still at 2.15. Hugin built without issue (though a couple other packages didn't )-: ). Which is a bit strange since that error looks like a build script issue. Tried rebuilding boost? –  Mat Sep 1 '13 at 9:08

1 Answer 1

up vote 1 down vote accepted

It is caused by a problem in boost-1.5, the include directory is not remove, and causing the Hugin compiling script to use the wrong header file.

Manually remove the orphaned directory solve the problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.