Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

After partitioning the drive and installing archlinux after reboot I get this error:

piix4_smbus 0000:00:07.3: Host SMBus controller not enabled.
sda1: WRITE SAME failed. Manually zeroing.

Then enters emergency mode.

share|improve this question
    
can you provide the contest from boot and kernel .log? –  vfbsilva Sep 4 '13 at 18:17
    
I think he mean contents, but ya do that :D –  krowe Sep 6 '13 at 14:07

1 Answer 1

WRITE SAME is part of SCSI Commands and its failure might be doing something with SMART capability of your hard disk.

  1. check in your BIOS and see if SMART is enabled. If not, enable it and try again.
  2. if 1 didn't work, you need to disable WRITE SAME somehow. This is one of the possible ways:
  • (before reboot) Find you device's write same control file, like this:

    $ sudo find /sys | grep max_write_same_blocks
    

    This would (hopefuly) give you the file path to control the WRITE SAME.

  • Create a file in /etc/tmpfiles.d called write_same.conf (this can be named anything as far as it is ended by .conf). Write this line in the file:

    w       /sys/devices/pci0000:00/0000:00:1f.2/ata1/host0/target0:0:0/0:0:0:0/scsi_disk/0:0:0:0/max_write_same_blocks     -       -       -       -       0
    

    (I've used my own system's path, might not work for you)

Now, try again.

Let me know if it worked for you. Good luck.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.