Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have just installed Archlinux & openbox but i have to say i am a bit dissapointed that the applications have this dull greyish (win 95) look:

enter image description here

On the picture there are two programs open which are gedit and gcalc which they both use GTK themes. I fixed those to look better by installing lxappearance and setting Adwaita theme. The calculator now looks way better while gedit doesn't:

enter image description here

I mean they both use GTK themes. Why don't both look better?


Then there is another side to this topic. I am using Kile and this one uses QT theme. How can i make it look like a real QT application - like the ones on KDE desktop? If this is impossible how can i at least make it look like a GTK app?

It looks dull atm: enter image description here


EDIT 1 After applying the solution my Archlinux with openbox desktop manager looks like this:

enter image description here

EDIT 2 The only problem I've had with the look of applications from this point on was with the propietary software like VLC and Eagle. Look of the first one can be corrected by opening VLC and in /tools/perefferences/interface choosing GTK+. I haven't found the solution for the later one yet...

share|improve this question
add comment

1 Answer

up vote 3 down vote accepted

One application is using GTK2 and the other is using GTK3 (unless I'm mistaken). Thus, you need to switch to a theme with both GTK2 and GTK3 components. One theme that supports both is Phenix, but if you search you can find many others. Most GTK3 themes on OpenDesktop.org also support GTK2.

As for Qt, install qtconfig (I'm sure Arch has some version of it available) and use that program to set the appearance of Qt applications. It provides an option to emulate the current GTK+ theme, which will allow maximum uniformity, and also an option for the default KDE theme.

share|improve this answer
    
First things first. I have installed Phenix theme and now I need to use it. I know that in order to usit for GTK3 applications I have to specify it in the file ~/.config/gtk-3.0/settings.ini under section gtk-theme-name=. Where do I specify it for the GTK2 applications? –  71GA Aug 29 '13 at 16:45
    
Have you tried lxappearance? My theme switcher does it for me. –  Wutaz Aug 29 '13 at 17:18
    
I did use lxappearance but Gedit didnt seem to change - I discovered now that I always opened it using sudo gedit. When i open it using only gedit it uses GTK. So i have to somehow set the GTK theme for root? How can this be achieved? –  71GA Aug 29 '13 at 18:29
    
I made the openbox use GTK theme for root user (command sudo) by opening lxapearance with sudo lxappearance and then applying the GTK theme. NOW all of my GTK based apps look nice :). But still there are those ugly QT apps like Kile which look horrible... Now i only need somenoe to tell me how to get the QT applications (like Kile) using oxygen theme and to look just like they were opened in KDE instead in openbox. –  71GA Aug 30 '13 at 9:31
    
I solved Kile thing by installing the qt and then using qtconfig-qt4 / sudo qtconfig-qt4 commands. These open a settings in which we can under Appearance tag choose GTK+. This settings only apply for GTK4 (user & root are set sepparately as i already explained) and therefore we have to repeat both command for GTK3 as well. So we use qtconfig-qt3 / sudo qtconfig-qt3 commands and repeat the procedure (notice we canno't choose GTK+ for QT3 and therefore QT3 applications are doomed to that old win 95 look). –  71GA Aug 30 '13 at 10:15
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.