Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have Debian 6, I have also seen this under Ubuntu (can not remember how I fixed it).

I can hibernate, but when I switch on the system cold boots (it does not restore previous session).


Note suspend works fine. Have looked in /var/log/pm-suspend.log Shows for each suspend suspend block a resume suspend block, but hibernate hibernate' is not followed byresume hibernate` ( I assume that is what is expected.


Installed package hibernate, as was thinking it may be needed, but made no difference.


I just started looking and can't find /usr/lib/hal/scripts/linux/hal-system-power-hibernate-linux or /usr/lib/hal I searched for power files (is it all there?:

find /usr/lib -iname "*power*"
/usr/lib/libupower-glib.so.1
/usr/lib/klibc/bin/poweroff
/usr/lib/python2.6/dist-packages/axiom/test/test_powerup.pyc
/usr/lib/python2.6/dist-packages/axiom/test/test_powerup.py
/usr/lib/upower
/usr/lib/upower/upowerd
/usr/lib/libupower-glib.so.1.0.1
/usr/lib/gnome-power-manager
/usr/lib/pymodules/python2.6/OpenGL/raw/GL/ARB/texture_non_power_of_two.pyc
/usr/lib/pymodules/python2.6/OpenGL/raw/GL/ARB/texture_non_power_of_two.py
/usr/lib/pymodules/python2.6/OpenGL/GL/ARB/texture_non_power_of_two.pyc
/usr/lib/pymodules/python2.6/OpenGL/GL/ARB/texture_non_power_of_two.py
/usr/lib/pymodules/python2.6/coherence/upnp/services/servers/switch_power_server.py
/usr/lib/pymodules/python2.6/coherence/upnp/services/servers/switch_power_server.pyc
/usr/lib/pymodules/python2.6/coherence/upnp/services/clients/switch_power_client.pyc
/usr/lib/pymodules/python2.6/coherence/upnp/services/clients/test/test_switch_power_client.py
/usr/lib/pymodules/python2.6/coherence/upnp/services/clients/test/test_switch_power_client.pyc
/usr/lib/pymodules/python2.6/coherence/upnp/services/clients/switch_power_client.py
/usr/lib/pymodules/python2.6/coherence/upnp/core/xml-service-descriptions/SwitchPower1.xml
/usr/lib/pm-utils/power.d
/usr/lib/pm-utils/power.d/sched-powersave
/usr/lib/pm-utils/sleep.d/00powersave
/usr/lib/rhythmbox/plugins/power-manager
/usr/lib/rhythmbox/plugins/power-manager/libpower-manager.so
/usr/lib/rhythmbox/plugins/power-manager/power-manager.rb-plugin
share|improve this question
    
Do you have a swap partition or just a swap file? Hibernating to a swap file is supported in theory but sometimes requires some hand-holding. Swap partitions should work out of the box (at least they do on Debian 5). –  Gilles Mar 8 '11 at 18:32
    
it is a partition –  richard Mar 8 '11 at 19:04
    
This issue has now fixed it self, there is nothing in synaptics history to say that I installed something to fix it. It may have been an update, are these in the same history log? BUT Redetection of my 'option' modem is now slower. –  richard Mar 29 '11 at 14:17

2 Answers 2

I've just had to deal with this on a laptop running Debian Testing (Jessie/Sid).

Possibly relevant: swap partition on an LVM volume (non-encrypted) at /dev/vg1/swap.

To make the system resume after hibernation, I had to edit /etc/default/grub and change

GRUB_CMDLINE_LINUX=""

to

GRUB_CMDLINE_LINUX="resume=/dev/mapper/vg1-swap"

and then run update-grub.

If you'd rather the kernel didn't check for resume images when you choose a recovery option from the GRUB menu, you'd want to modify GRUB_CMDLINE_LINUX_DEFAULT instead of GRUB_CMDLINE_LINUX.

I would have expected update-grub to write any necessary resume= parameters into /boot/grub/grub.cfg on its own, without my needing to be this explicit about it.

However, the only mention of resume= inside the script fragments in /etc/grub.d is in a piece that has something to do with OSX support. Not sure what's going on there.

share|improve this answer

This is a common issue for hibernate and suspend in Ubuntu / Debian.

install uswsusp

sudo apt-get install uswsusp

then try the following for suspend and hibernate respectively,

sudo s2ram

sudo s2disk

if it works, then you can make it permanent, back up the following,

sudo cp /usr/lib/hal/scripts/linux/hal-system-power-suspend-linux /usr/lib/hal/scripts/linux/hal-system-power-suspend-linux.bak

sudo cp /usr/lib/hal/scripts/linux/hal-system-power-hibernate-linux /usr/lib/hal/scripts/linux/hal-system-power-hibernate-linux.bak

and edit the following,

/usr/lib/hal/scripts/linux/hal-system-power-suspend-linux

#!/bin/sh
/sbin/s2ram –force

/usr/lib/hal/scripts/linux/hal-system-power-hibernate-linux

#!/bin/sh
/sbin/s2disk
share|improve this answer
    
I am thinking that this is an alternative suspend/hibernate subsystem. I will try if can't fix the current one. –  richard Mar 8 '11 at 13:25
    
right, let us know the result. you need to install the proper drivers for it to work. this is just an alternative. –  Joset Mar 8 '11 at 14:03
    
can't find /usr/lib/hal/scripts/linux/hal-system-power-hibernate-linux see question –  richard Mar 9 '11 at 10:49
    
I have discovered that the uswsusp package is missing from debian squeeze. I could get it from testing or unstable repository, but have to be careful about not pulling in other dependencies. I would like to know if it will fix it. Is uswsusp needed for hibernate. Or should pm-utils be enough. (suspend it ram is working fine.) –  richard Mar 18 '11 at 18:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.