Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am trying to install a program called Glype on my computer for a proxy. I am using Backtrack 5 R3 and I have the latest version of Apache running on it. The problem I have is that Glype needs cURL to run and when I try to install cURL using: "apt-get install php5-curl" it displays an error. It says-

"Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies: php5-curl: Depends: php5-common (= 5.3.2-1ubuntu4.9) but 5.3.2-1ubuntu4.17 is to be installed"

So is there a way that I can install it without having any errors?

share|improve this question
add comment

1 Answer

Backtrack's repositories are no longer maintained (in fact, they are packages from Ubuntu 11.10 version), so it's no wonder you have dependencies issues.

The best solution is changing from BackTrack to Kali Linux, which is the now maintained distribution. In this you can corroborate that all packages are available and updated from Debian stable repositories:

$ apt-cache show php5-curl
Package: php5-curl
Source: php5
Version: 5.4.4-14+deb7u2
Installed-Size: 112
Maintainer: Debian PHP Maintainers 
Architecture: i386
Depends: libc6 (>= 2.4), libcurl3 (>= 7.16.2), phpapi-20100525+lfs, php5-common (= 5.4.4-14+deb7u2), ucf
Pre-Depends: dpkg (>= 1.15.7.2~)
$ apt-cache policy php5-curl
php5-curl:
  Installed: (none)
  Candidate: 5.5.1+dfsg-2
  Version table:
     5.4.4-14+deb7u2 0
        500 http://http.kali.org/kali/ kali/main i386 Packages
$ apt-cache policy php5-common
php5-common:
  Installed: (none)
  Candidate: 5.5.1+dfsg-2
  Version table:
     5.4.4-14+deb7u2 0
        500 http://http.kali.org/kali/ kali/main i386 Packages

As you notice, Kali repositories has no dependencies problems with this.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.