Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My base system is Gentoo amd64, up to date. Before the upgrade, I have the shutdown button in the KDE menu. But after the upgrade, this button is gone...I think it is because of the permission settings are wrong. The user account I used is in the user group. But I have no idea how the set the permission. I even tried to delete the KDE configuration files in the user directory and try to re-configure everything, but does not work.

share|improve this question
You can try this. Have you tried to create a new account to see if the shutdown button is there? – Alko Aug 23 '13 at 14:03
@Alko, I have tried. No shutdown button for the new user. I think it is a system wide configuration issue. – davidshen84 Aug 25 '13 at 2:34
I have find out this issue is related to polkit, not KDE itself...however I still cannot find a fix :( – davidshen84 Aug 25 '13 at 13:32
up vote 2 down vote accepted

The configuration file /etc/config/kdm/kdmrc has the following section:

# The command (subject to word splitting) to run to halt the system.
# Default is "/sbin/shutdown -h -P now"
# HaltCmd=
# The command (subject to word splitting) to run to reboot the system.
# Default is "/sbin/shutdown -r now"
# RebootCmd=
# Whether it is allowed to shut down the system via the global command socket.
# Default is false
# AllowFifo=true
# Whether it is allowed to abort active sessions when shutting down the
# system via the global command socket.
# Default is true

Un-comment the "AllowFifo=true" line, then the system shutdown as it used to before the latest upgrade. Source and info As long as this is correct you can add a shutdown launcher.

share|improve this answer
I am not using kdm, I use lightdm. So I don't have this config. file at all :( – davidshen84 Aug 25 '13 at 3:28

Switch to systemd fix this permission issue.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.