Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have a 1900x1080 resolution monitor, and after installing Fedora to create a dual boot machine, the maximum resolution Fedora 14 (previously only Windows 7 was installed) can achieve is 1280x1024. Why is this the case? How do I figure out what to do to get full native resolution on my monitor in Fedora?

share|improve this question
    
What is your graphics card? –  mattdm Mar 7 '11 at 23:41
    
I'm not sure. How do I find that out? –  jonderry Mar 7 '11 at 23:52
    
Is it a laptop? If so, what make/model? We could probably point you toward a driver to install. Nvidia is easy. If its a desktop, open it up and look! –  Mr. Shickadance Mar 8 '11 at 0:06
    
It's a desktop, with a 1GB DDR3 AMD Radeon HD 6450 graphics card. –  jonderry Mar 8 '11 at 0:20
add comment

2 Answers 2

up vote 5 down vote accepted

So, this appears to be a really new graphics card. You'll need both an up-to-date X driver and a really recent kernel — in fact, you need the not-yet-released (as of early March 2011) 2.6.38 kernel. (See this article for more on the upcoming kernel release.)

The good news is that the pre-release 2.6.38 kernel is already in the tree for Fedora 15, and the Fedora 15 Alpha release is scheduled for tomorrow today (March 8th, 2011). Get the release from http://torrent.fedoraproject.org/.

I can't promise that that'll make the card work, but the signs look positive. I'm not sure if the needed driver code is in the F15 X.org drivers yet, but the quickest way to find out is to try it.

You can even get the Live Desktop CD option, which will let you test if it works without even reinstalling.

It's possible (likely even) that the required bits will make it into Fedora 14 in a few months. So just waiting is another option.

(Honestly, I think either of those will be a better option than the proprietary binary driver. I've had no end of trouble from that. It's faster at 3D, so if top 3D performance is your main need, it might be worth it, but for general use, eh.)


Update: So, Fedora 15 (final release) is out today. I'm curious — did it work?

share|improve this answer
    
Right, but IME the proprietary driver is only faster in 3D, much slower in 2D than the open-source driver. –  Keith Mar 8 '11 at 8:40
    
@Keith — thanks, good to know. –  mattdm Mar 8 '11 at 13:41
    
You are really fast, I was just about to say that F15 alpha is out :) –  phunehehe Mar 8 '11 at 17:45
    
Can you explain why I need the 2.6.38 kernel rather than just the driver? I don't need 3D at all, just the higher resolution. –  jonderry Mar 8 '11 at 18:00
    
@jonderry, with modern kernels and X, graphics cards are initialized by the kernel. See unix.stackexchange.com/questions/7943 and kernelnewbies.org/…, and the link to h-online in my answer above. Support for your card's family was just now added. –  mattdm Mar 8 '11 at 18:05
show 16 more comments

Most likely you don't have the driver installed. You have 2 choice:

  1. Use a proprietary driver. You can get proprietary drivers through the manufacturer's website, in this case it's the AMD's download page. Some distros also have proprietary drivers in the repositories. For Fedora check out this Unofficial Fedora FAQ.
  2. Use an opensource driver. This is often not as good as the proprietary one, unless the manufacturer has provided the specifications to opensource developers, in which case it is better. Look into your distro's documentation on how to get opensource drivers. I don't know if this exists for Fedora, though.
share|improve this answer
    
OK, I installed the driver, but the max resolution has not changed. It's still 1280x1024 (native is 1900x1080). Is there any way to verify that the correct driver is installed, or is there another explanation for why I can't get more resolution? –  jonderry Mar 8 '11 at 2:32
    
Fedora will have a pretty recent version of the Radeon driver; at least one of the driver authors works for Red Hat. But this seems to be a rather recent card. –  mattdm Mar 8 '11 at 2:37
1  
@jonderry Then maybe you can try creating xorg.conf –  phunehehe Mar 8 '11 at 3:26
1  
But then also see my answer, because no amount of editing the config file will actually help in this case. :) –  mattdm Mar 8 '11 at 3:56
1  
@phunehehe -- for the open source driver, I think it's pretty clear. For the proprietary one, I don't know, but in general modern drivers do a pretty good job of selecting the best possible resolution automatically, so I'd be really surprised if there's anything that can be done in that case either. –  mattdm Mar 8 '11 at 4:27
show 7 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.