Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I, actualy, don't know where to ask this, but this can be related to Linux.

Firefox on Arch Linux always asks about download destination, even if there's a default download destination folder set up through options interface or even about:config.

How can I fix that?

Additional info:

It's been normal till 22.0. I've tried to re-create profile or even create new, clean one, and try there and still got the same problem.

I've also tried to ask this question on #firefox @ freenode, but haven't got any reply.

share|improve this question
    
Shouldn't this be on SuperUser? –  rahmu Aug 23 '13 at 8:38
    
I wasn't sure where to post this, so, I've posted it here. –  Ivan Kolmycheck Aug 23 '13 at 8:53

1 Answer 1

up vote 2 down vote accepted

Go to the address bar, and type about:config. Accept the following warranty void notification and proceed.

You will now see a list of preferences. Right click anywhere, and select New to create a new preference. Set the preference name as browser.download.dir and the preference value as your destination directory -- say, /home/user/my_files. Now, if your type in the preference name in the search bar above, the new entry will be displayed.

Now, in the above search bar, type browser.download.folderList. Double click on the entry displayed below, and change the value to 2.

Now, try downloading any file, and check if it works. It at least worked for me.

Source: http://forum.xda-developers.com/showthread.php?t=802592

Further information about:config entries: http://kb.mozillazine.org/About:config_entries

share|improve this answer
    
Works for me, thank you. –  Ivan Kolmycheck Aug 24 '13 at 8:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.