Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have an HP HDX16-1354CA Laptop that I've installed Fedora 19 on, and my ethernet port is not being detected. I am sure that it is because I have not installed the drivers for it, but I can't seem to find any proprietary ethernet drivers for linux anywhere. Is there some way to search for all proprietary drivers that match your system, like Ubuntu does with the "Additional Drivers" option? The windows equivalent to the driver that I need is the Realtek PCI-E Fast Ethernet NIC Driver.

share|improve this question
    
You can find out the exact model number of your card from lspci|grep -i ethernet. The bad news, though, is that Ethernet is usually supported "out-of-the-box" on Linux. The only two cases I've seen where Ethernet didn't work in Linux were either because the NIC was faulty or the model wasn't supported in Linux at all. –  Joseph R. Aug 21 '13 at 8:53
    
Exactly. I'm not sure what card model is in your laptop but if it was RTL810x, you could try a Linux driver provided by Realtek at tinyurl.com/myjblzc . –  dsmsk80 Aug 21 '13 at 9:00
    
Checked the card model:03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168 PCI Express Gigabit Ethernet controller (rev 02) I also tried to get the Realtek driver from that link, but I get this error when I run it: make: *** /lib/modules/3.10.3-300.fc19.x86_64/build: No such file or directory. Stop. Pretty sure it's because my model type is RTL811X, but any guidance from here? –  Brad Aug 21 '13 at 9:20
1  
You don't have installed kernel-devel package, install it first and then continue with the procedure written in the readme file from the driver package. –  dsmsk80 Aug 21 '13 at 9:40
    
I ran sudo yum install kernel-devel and it loaded a couple plugins then said "nothing to do". I then ran the autorun file again, it still said the same thing. I actually have the folder that it is referring to (/lib/modules/3.10.3-300.fc19.x86_64/build) I just don't know why it can't find it. –  Brad Aug 22 '13 at 3:29

1 Answer 1

To install Ethernet driver on Fedora 19:

Step 1: Install the follwing rpm packages on your computer:

cpp-4.8.1-1.fc19.x86_64.rpm
gcc-4.8.1-1.fc19.x86_64.rpm
gcc-c++-4.8.1-1.fc19.x86_64.rpm
glibc-2.17-14.fc19.x86_64.rpm
glibc-common-2.17-14.fc19.x86_64.rpm
glibc-devel-2.17-14.fc19.x86_64.rpm
glibc-headers-2.17-14.fc19.x86_64.rpm
kernel-devel-3.9.5-301.fc19.x86_64.rpm
kernel-headers-3.9.5-301.fc19.x86_64.rpm
libmpc-1.0.1-1.fc19.x86_64.rpm
libstdc++-devel-4.8.1-1.fc19.x86_64.rpm
perl-5.16.3-264.fc19.x86_64.rpm
perl-Carp-1.26-243.fc19.noarch.rpm
perl-Encode-2.51-1.fc19.x86_64.rpm
perl-Filter-1.49-1.fc19.x86_64.rpm
perl-libs-5.16.3-264.fc19.x86_64.rpm
perl-macros-5.16.3-264.fc19.x86_64.rpm
perl-PathTools-3.40-1.fc19.x86_64.rpm
perl-Pod-Escapes-1.04-264.fc19.noarch.rpm
perl-Pod-Simple-3.20-264.fc19.noarch.rpm
perl-Scalar-List-Utils-1.27-246.fc19.x86_64.rpm
perl-Socket-2.009-2.fc19.x86_64.rpm
perl-threads-1.87-1.fc19.x86_64.rpm
perl-threads-shared-1.43-2.fc19.x86_64.rpm

Step 2: Download compat-drivers-2013-03-04-u.tar.bz2 then run the commands:

# tar -xf compat-drivers-2013-03-04-u.tar.bz2
# cd compat-drivers-2013-03-04-u
# ./scripts/driver-select alx && make && make install
# reboot
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.