Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I want to upgrade my server so I ran apt-get dist upgrade but I keep having this error:

Unpacking replacement aptitude ...
dpkg-deb: file `/var/cache/apt/archives/aptitude_0.6.8.2-1_armel.deb' contains ununderstood data member data.tar.xz     , giving up
dpkg: error processing /var/cache/apt/archives/aptitude_0.6.8.2-1_armel.deb (--unpack):
 subprocess dpkg-deb --fsys-tarfile returned error exit status 2
dpkg: considering deconfiguration of aptitude, which would be broken by installation of aptitude-common ...
dpkg: yes, will deconfigure aptitude (broken by aptitude-common).
Unpacking aptitude-common (from .../aptitude-common_0.6.8.2-1_all.deb) ...
De-configuring aptitude ...
dpkg-deb: file `/var/cache/apt/archives/aptitude-common_0.6.8.2-1_all.deb' contains ununderstood data member data.tar.xz     , giving up
dpkg: error processing /var/cache/apt/archives/aptitude-common_0.6.8.2-1_all.deb (--unpack):
 subprocess dpkg-deb --fsys-tarfile returned error exit status 2



Errors were encountered while processing:                                       
 /var/cache/apt/archives/aptitude_0.6.8.2-1_armel.deb                           
 /var/cache/apt/archives/aptitude-common_0.6.8.2-1_all.deb                      
E: Sub-process /usr/bin/dpkg returned an error code (1) 

Here's some of what I've tryied:

sudo apt-get dist-upgrade
sudo dpkg --configure -a
sudo ldconfig
sudo apt-get check
sudo apt-get -f install
sudo apt-get -f upgrade --fix-missing

Always ending with the same errors so I can't do anything else.

What should I do?

share|improve this question
    
Exactly what sort of "server" is this? And, where are the rest of the error messages? –  Michael Hampton Aug 20 '13 at 15:33
    
I'm using a Guru Plug . I added previous errors to the question. Thanks –  AAlvz Aug 20 '13 at 15:50
    
I also have this warning: WARNING: The following packages cannot be authenticated! aptitude aptitude-common apt-utils libapt-pkg4.12 apt –  AAlvz Aug 20 '13 at 15:52
1  
Reinstall from scratch? –  Zoredache Aug 20 '13 at 16:10
    
@MichaelHampton question updated =) –  AAlvz Aug 20 '13 at 16:24
show 1 more comment

migrated from serverfault.com Aug 21 '13 at 2:15

This question came from our site for professional system and network administrators.

3 Answers

You are updating your system to Debian wheezy (current stable), not to squeeze (oldstable) as you wrote in the title of the question.

I guess that you have a pre-squeeze system (Lenny, Etch, ...). So you are skipping at least one version. This is not supported and the reason why dpkg cannot unpack the package files (because of the 'new' .xz compression).

The solution is to update stepwise: So for Lenny, first to squeeze and then to wheezy. A fresh installation of the whole system might also be an option.

If your system is really old, you might have troubles to find the next newer version on the regular download servers. Use then http://snapshot.debian.org .

share|improve this answer
    
xz compression is new in wheezy? –  Faheem Mitha Nov 21 '13 at 13:11
    
@FaheemMitha Not exactly. Dpkg supports xz since Debian Squeeze. But it is actually used since Wheezy, so Squeeze system (but not older ones) can be upgraded to Wheezy. Changes in the package format can only become effective in the release after the changes was done, otherwise there is no upgrade possibility. –  jofel Nov 21 '13 at 13:22
    
I see. Thanks for the clarification. –  Faheem Mitha Nov 21 '13 at 16:33
add comment
sudo dpkg -r aptitude_0.6.8.2-1_armel
sudo apt-get -f install
sudo apt-get update
sudo apt-get upgrade

Fix broken package

Fix apt

share|improve this answer
    
I tried that and got the same... well. when I tried for the second time I got dpkg - warning: ignoring request to remove aptitude-common_0.6.8.2-1_all which isn't installed. which is obvious, but trying to install again led me to the error in the quetion –  AAlvz Aug 20 '13 at 15:47
    
are u able to install any other package using apt-get? –  Harikrishnan Aug 20 '13 at 15:49
    
No. I can't install anything now. –  AAlvz Aug 20 '13 at 15:51
    
try iasptk.com/ubuntu-debian/… –  Harikrishnan Aug 20 '13 at 16:41
add comment

Sorry for not providing a real answer. This is just a pointer towards the solution, as nobody seemed to see it.

The error message states that the package inside the DEB file is not a

.tar.gz
, but a
.tar.xz

This means it has been compressed using lzma. If apt/dpkg may be informed of how to unpackage those files, it should do the trick.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.