Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm getting an occasional "Authentication request" dialog from Gnome, and I don't know what program is asking or even which account it's talking about.

enter image description here

[email redacted] is an email address of mine, but I've used that address for more than one account, and they all have different passwords. I don't know what it's asking for. This dialog tends to pop up when I unlock the computer after having been away for a while. I just click Cancel, and the dialog goes away for a while. I don't get any other message when I do that.

I'm running Gnome 3.8.3 on Arch Linux.

Note: After writing this question, I thought of checking Online Accounts in Gnome Settings. I noticed that it showed my Google account (under that email) as "credential expired". Is that what was causing it? I signed back in to my Google account, but it's too soon to tell if that fixed the problem. And I still want to know how to tell who's asking for my password (and for which account).

share|improve this question
    
Wild guess: Do you have any permanent connection to a google or social media account? –  Bananguin Aug 19 '13 at 6:45
    
Just the process showing the window? The one really asking the password could be not so easy –  Alex Aug 19 '13 at 19:44
    
Possibly related: askubuntu.com/questions/207337/… –  paraxor Aug 19 '13 at 23:18

4 Answers 4

You can use xprop, available in the xorg-xprop package.

Just run xprop and select the password prompt window. As an example, xprop outputs the following information for my terminal emulator.

WM_STATE(WM_STATE):
        window state: Normal
        icon window: 0x0
WM_LOCALE_NAME(STRING) = "en_US.UTF-8"
WM_CLASS(STRING) = "screen-256color", "screen-256color"
WM_HINTS(WM_HINTS):
        Client accepts input or input focus: True
WM_NORMAL_HINTS(WM_SIZE_HINTS):
        program specified size: 564 by 340
        program specified resize increment: 7 by 14
        program specified base size: 4 by 4
WM_CLIENT_MACHINE(STRING) = "paradark"
WM_NAME(STRING) = "st"
WM_PROTOCOLS(ATOM): protocols  WM_DELETE_WINDOW

The WM_NAME field may be especially useful in your case.


xprop will not work if you are unable to select the window. You can use xwininfo instead. xwininfo is available in the xorg-xwininfo package. Here is an example of its usage:

$ xwininfo -display :0 -tree -root
xwininfo: Window id: 0x286 (the root window) "LG3D"

  Root window id: 0x286 (the root window) "LG3D"
  Parent window id: 0x0 (none)
     21 children:
     ...
     0x1a00001 "st": ("screen-256color" "screen-256color")  862x532+1056+546  +1056+546
     0x1600001 "st": ("screen-256color" "screen-256color")  1054x1065+-2112+13  +-2112+13
     0x600001 "st": ("screen-256color" "screen-256color")  862x532+-1728+546  +-1728+546
     0x400004 (has no name): ()  1x1+0+0  +0+0

If you need additional information about the window, use xprop with the window's ID.

$ xprop -display :0 -id 0x600001
WM_STATE(WM_STATE):
        window state: Normal
        icon window: 0x0
WM_LOCALE_NAME(STRING) = "en_US.UTF-8"
WM_CLASS(STRING) = "screen-256color", "screen-256color"
WM_HINTS(WM_HINTS):
        Client accepts input or input focus: True
WM_NORMAL_HINTS(WM_SIZE_HINTS):
        program specified size: 564 by 340
        program specified resize increment: 7 by 14
        program specified base size: 4 by 4
WM_CLIENT_MACHINE(STRING) = "paradark"
WM_NAME(UTF8_STRING) = "st"
WM_PROTOCOLS(ATOM): protocols  WM_DELETE_WINDOW
share|improve this answer
    
I'm not sure xprop will work, because the authentication dialog takes over the entire screen. I can Alt+Control+F2 to get a text login prompt, and I can run xprop there by explicitly specifying the display to use, but I don't know if it'll work on the authentication dialog. I'll have to try it if it happens again. –  cjm Aug 19 '13 at 21:49
    
wmctrl -lp will list all the windows even from a vt as root (need DISPLAY in the env) –  Alex Aug 19 '13 at 23:07
    
@cjm: I have added an alternative solution to my answer. –  paraxor Aug 19 '13 at 23:10
    
You can also use the command xlsclient -l to get a list of all the windows present on a system. –  slm Aug 20 '13 at 1:51
    
In the previous comment I forgot to specify, the windows and their pid. –  Alex Aug 21 '13 at 11:38

I had a similar problem; here is my situation. I have my account info setup in Evolution, minus my password. Everytime I type something in the GNOME search bar, it asks for my password.

The closest thing to solving my problem was at 12.10 - Access Prompt keeps asking for password - Ask Ubuntu, but only so far as the following

In my particular case, I had to also stop Evolution from checking my Gmail account before this dialog box went away completely.

but I found no such setting in Evolution. So I considered that GNOME was the culprit, imagining it was searching mail, and vaguely recalled a settings menu item for Search.

I went to Gnome settings, and under the first group, Personal, I selected Search. Mail is not, but Contacts was. I deselected Contacts, and the GNOME search bar seems to behave better now.

share|improve this answer

I had this problem when I inadvertently entered an incorrect password for my Google account.

I resolved it by opening Seahorse (Passwords & Keys), finding the entry for GOA google credentials... and DELETING it.

I then logged in to GNOME again and opened Online Accounts.

I signed in to my Google account with the correct password and that was it.

share|improve this answer

I also had this problem... and I finally decided to fix it.

I also did what polym suggested and found that I had three entries for 'google credentials'.

Specifically:

  1. Open seahorse (Passwords and Keys)
  2. Select 'Login' under 'Passwords'
  3. In the search window type 'gnome'
  4. Delete all entries that begin with 'GOA google credentials for identity account_blahblah'
  5. Close 'Passwords and Keys'
  6. Open Settings --> Online Accounts
  7. Delete the entry for 'Google' ( '-' button)
  8. Add the entry back ('+' button) and do what the dialog says.
  9. Close 'Online Accounts'

So far it appears to have been effective.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.