Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I booted up elementary OS the other day and wanted to get rid of the windows partition so I could resize my elementary partition. I used GParted to add the boot flag to the mac partition and removed it from the elementary partition. Now when I start my computer it starts to boot and goes to a black screen displaying "Missing Operating System....". I tried using the mac OS install disc, then windows and then I got a friend to install the elementary ISO to a USB drive and that didn't work either. I've gotten it to a prompt to boot from a CD or DVD using my android phone with the .ISO on it but that also doesn't work. I've also tried holding ALT at startup with my mac OS X install disc to no avail and none of the listed Mac startup key commands have done anything. I'm using an Intel-iMac with OS X Snow Leopard. Any and all help would be appreciated.

share|improve this question
    
to me this looks like the grub has been affected by deleting that partition. have you tried repairing grub? look here –  cipricus Sep 26 '13 at 16:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.