Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am using LMDE (Linux Mint Debian Edition).
By default, this ships with a quite old Firefox version (21.0). And if you install Iceweasel, it does not get better.

There are a number of forum posts about installing a newer version of Iceweasel OR Firefox. Ultimately a lot of them lead here: http://mozilla.debian.net/, where I am asked to add this repository to /etc/apt/sources.list

deb http://cdn.debian.net/debian experimental main

and to install as follows

$ apt-get update
$ apt-get install -t experimental iceweasel

Unfortunately, this gets me into the following error:

The following packages have unmet dependencies:
 iceweasel : Depends: libc6 (>= 2.17) but 2.13-37 is to be installed
             Depends: xulrunner-23.0 (>= 23.0-2) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

If this is relevant, here is my /etc/apt/sources.list

deb http://packages.linuxmint.com/ debian main upstream import
deb http://mirror.rts-informatique.fr/linuxmint/debian/latest testing main contrib non-free
deb http://mirror.rts-informatique.fr/linuxmint/debian/latest/security testing/updates main contrib non-free
deb http://mirror.rts-informatique.fr/linuxmint/debian/latest/multimedia testing main non-free

deb http://repository.spotify.com stable non-free

# Opera sources added by smxi
deb http://deb.opera.com/opera sid non-free

# for Iceweasel 4
deb http://cdn.debian.net/debian experimental main

and my /etc/apt/sources.bk (which is probably just a backup file, is it?)

deb http://packages.linuxmint.com/ debian main upstream import
deb http://debian.linuxmint.com/latest testing main contrib non-free
deb http://debian.linuxmint.com/latest/security testing/updates main contrib non-free
deb http://debian.linuxmint.com/latest/multimedia testing main non-free
share|improve this question
    
I should add, I prefer to install stuff with apt-get as opposed to directly downloading it. –  donquixote Aug 14 '13 at 2:08
    
Have your tried a dist-upgrade? Be very careful with the libc package(s) it's a core dependency. –  justbrowsing Aug 14 '13 at 2:29
    
going to try that, thank you - we'll see :) I'm going to remove the "experimental" line from sources.list before dist-upgrade, who knows what effect it could have.. –  donquixote Aug 14 '13 at 3:56
    
dist-upgrade does nothing. not really surprising, considering that lmde is a "running release". –  donquixote Aug 14 '13 at 4:00
add comment

1 Answer

Lucky you, I decided to create a LMDE Virtual Machine just to answer this question.

Like you, I tried a few things (add-apt-repository)

  • the firefox-next PPA on Launchpad [ppa:mozillateam/firefox-next] (no change)
  • enabling the Mint unstable "romeo" repo (no change)
  • installing the packages from debian experimental repo [deb mozilla.debian.net/ experimental iceweasel] (no change)
  • running dist-upgrade from debian unstable repo [deb ftp.debian.org/debian unstable main] (successfully worked with iceweasel 23 until rebooting borked the install)

Thought about just compiling firefox from source.

Unfortunately, the only other option that I'm aware of (besides waiting) is to repackage the .deb package from the firefox-next PPA and change the dependencies listed. You would have to do that for each version though (and hope the only difference is the ~ubuntu appended to the version number rather than compiled against a different version)

If a real rolling release is important to you and you're comfortable with CLI then I'd highly recommend taking the leap to ArchLinux or Gentoo.

share|improve this answer
    
sorry, my reputation does not allow to vote you up :( but thanks for the effort! –  donquixote Aug 14 '13 at 17:03
    
Are ArchLinux and Gentoo generally better maintained than LMDE? –  donquixote Aug 14 '13 at 17:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.