Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

We have proxy-server and I run Linux Mint 15 Mate. I've set up network connection and Firefox prompts for login/pass and then connects to Internet. When trying to look for updates/new software, system does not prompt for login/pass and cannot connect to Internet. What should be done to have system accessing Internet and getting updates/installing new software?

share|improve this question

2 Answers 2

# man apt.conf
...
....
   http
       http::Proxy sets the default proxy to use for HTTP URIs
....

You need to edit config file: /etc/apt/apt.conf to configure APT package handling utility.

Additionally read about ProxyChains - redirect connections through proxy servers.

share|improve this answer
    
ProxyChains is not exactly what I need. As for editing apt.conf, it did not help. Still cannot connect to repositories to update system or anything like this. It is interesting that Firefox has access through login/pass prompt, whereas Chromium doesn't. I tried to set up it using command chromium-browser --proxy-server=server:port, but it still does not connect. –  javlon Aug 14 '13 at 11:10

Go to:
Package Manager -> Settings -> Network
Re-Enter your Proxy IP/Port and klick on Authentication to set login/pass

How to find Package Manager this could help: Mint: How to Open the Package Manager

share|improve this answer
    
Clicking on Authentication opens menu login/pass, but these windows remain inactive and I cannot fill them out. What's wrong? –  javlon Aug 14 '13 at 11:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.