Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried two methods to enable hibernation. First method was invoking

systemctl hibernate

under root. The second was to use Frippery Shut Down Menu.

In both cases the system will eventually show me a black screen with some error message and it does not hibernate. I have the latest updates installed. I believe this is a bug. How can I make hibernation work under Fedora 19?

share|improve this question
1  
Please add in hardware details and, also, what that "some error message" is. If its too long to type, feel free to use a camera to take a picture of the screen, and post that. – derobert Aug 12 '13 at 17:43
    
@slazer can you add the error messages. – Munai Das Udasin Aug 12 '13 at 18:10
    
Also check to see you have a linux swap partition (hibernate saves the contents of RAM to the HDD's swap partition) and that it is enabled. Does suspend(-to-RAM) work? – justbrowsing Aug 12 '13 at 18:12
up vote 2 down vote accepted

You may find that hibernation is not enabled by default in fedora's grub.cfg and/or fstab.

You need to have a large enough swap partition and an entry for it in /etc/fstab.

e.g.

UUID=da673383-0c15-4b6c-9eab-0d7e425b7d05 swap                    swap    defaults        0 0

And you need to set the resume option for linux through grub. I did that by adding resume=/dev/disk/by-uuid/da673383-0c15-4b6c-9eab-0d7e425b7d05 to /etc/defaults/grub

e.g.

GRUB_CMDLINE_LINUX="rhgb quiet acpi_osi=linux resume=/dev/disk/by-uuid/da673383-0c15-4b6c-9eab-0d7e425b7d05"

You then need to rebuild grub. I use efi, so to do it I ran grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg. You will need to change the -o option if your grub.cfg lives elsewhere in /boot.

Answer found on ORDINATECHNIC.

share|improve this answer

Try the following commands in sequence, as root; you cannot do this sudo because of the redirection:

echo shutdown > /sys/power/disk
echo disk > /sys/power/state

That is the most fundamental test of hibernate (all other means just use this in the end). So if that has a problem, then it is a kernel issue.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.