Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Bye all,

ping AddressIp
64 bytes from indirizzoIp: icmp_req=1 ttl=42 time=149 ms

while if

ping AddressIp -l 1400 
ping: cannot set preload to value > 3

ping AddressIp -t -l 1400
ping: can't set unicast time-to-live: Invalid argument

Why can't I ping?

share|improve this question
    
Sorry in not -p is -t. I root:root@ado-BackBox:~# ping AddressIp -t -l 1400 –  Aldo Aug 9 '13 at 10:07
    
Type id in the console –  rook Aug 9 '13 at 10:10

2 Answers 2

up vote 0 down vote accepted
ping AddressIp -l 1400 
ping: cannot set preload to value > 3

You need supervisor rights to access this feature of ping with value over than 3.

Try: sudo ping AddressIp -l 1400

UPDATE:

Do you want size option for your ping packets? I guess, in Windows option -l means size of the packet, but in linux world there is another option for that.

Try -s option: sudo ping AddressIp -s 1000 -l 1400

DE BENE ESSE

In Linux ping is going until you stop it, so you don't need the Windows ping -t option.

share|improve this answer
    
sudo ping ip-address -l 1400 = 64 bytes from mil01s16-in-f24.1e100.net (ip-address): icmp_req=2 ttl=56 time=13.7 ms –  Aldo Aug 9 '13 at 10:19
    
Is always 64 bytes –  Aldo Aug 9 '13 at 10:29
    
@Aldo see update of the answer –  rook Aug 9 '13 at 10:38
    
Thank! The command for size packets is -s. –  Aldo Aug 9 '13 at 11:09
    
@Aldo, if you find this answer is useful, you could accept it as answer :) –  rook Aug 9 '13 at 13:38

From ping's manpage:

-l preload
       If  preload is specified, ping sends that many packets not waiting 
       for reply.  Only the super-user may select preload more than 3.

-p pattern
       You may specify up to 16 ``pad'' bytes to fill  out  the  packet
       you send.  This is useful for diagnosing data-dependent problems
       in a network.  For example, -p ff will cause the sent packet  to
       be filled with all ones.

So make sure you run ping under super user and feed to -p option an argument.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.