Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am trying to perform full system update for my Gentoo 3.8.13 x86_64

emerge --update --deep --with-bdeps=y --newuse world

But I am getting the following error

!!! Problem resolving dependencies for media-video/vlc from @selected
... done!

!!! The ebuild selected to satisfy "media-video/vlc" has unmet requirements.

- media-video/vlc-2.0.7::gentoo USE="a52 aac alsa avcodec avformat cdda dbus dts dvbpsi dvd encode ffmpeg flac gcrypt gnome libnotify mmx mp3 mpeg ncurses ogg opengl png postproc pulseaudio qt4 samba sdl sse svg swscale truetype udev vorbis x264 xcb xml xv -X -aalib (-altivec) -atmo (-audioqueue) -avahi -bidi -bluray -cddb -dc1394 -debug -dirac (-direct2d) -directfb (-directx) (-dshow) -dvb (-dxva2) -egl -fbosd -fluidsynth -fontconfig -gme -gnutls -growl -httpd -ieee1394 (-ios-vout) -jack -kate -kde -libass -libcaca -libproxy -libsamplerate -libtar -libtiger -linsys -lirc -live -lua (-macosx) (-macosx-audio) (-macosx-dialog-provider) (-macosx-eyetv) (-macosx-qtkit) (-macosx-quartztext) (-macosx-vout) -matroska (-media-library) -modplug -mtp -musepack (-neon) -omxil -optimisememory -opus -oss -portaudio -projectm -pvr -rtsp -run-as-root -schroedinger -sdl-image -shine -shout -sid -skins -speex -sqlite -switcher -taglib -theora -twolame -upnp -v4l -vaapi -vcdx -vlm (-waveout) (-wingdi) -wma-fixed -xosd -zvbi"

The following REQUIRED_USE flag constraints are unsatisfied:

qt4? ( X ) sdl? ( X )

The above constraints are a subset of the following complete expression:

aalib? ( X ) bidi? ( truetype ) cddb? ( cdda ) dvb? ( dvbpsi ) dxva2? ( avcodec ) egl? ( X ) ffmpeg? ( avcodec avformat swscale postproc ) fontconfig? ( truetype ) gnutls? ( gcrypt ) httpd? ( lua ) libcaca? ( X ) libtar? ( skins ) libtiger? ( kate ) media-library? ( sqlite ) qt4? ( X ) sdl? ( X ) skins? ( truetype qt4 X ) switcher? ( avcodec ) vaapi? ( avcodec X ) vlm? ( encode ) xosd? ( X ) xv? ( xcb )

(dependency required by "@selected" [set])

(dependency required by "@world" [argument])

Can anyone suggest me, how can I perform a full update


Thanks to every one, It works when I add the X use flag in make.conf. but Now I got some message from the update,

* Messages for package x11-drivers/ati-drivers-13.4:

*   CONFIG_DRM must be disabled or compiled as a module and not loaded for direct
*   rendering to work.
* Please check to make sure these options are set correctly.
* Failure to do so may cause unexpected problems.
* 
* Please note that this driver only supports graphic cards based on
* Evergreen chipset and newer.
* This includes the AMD Radeon HD 5400+ series at this moment.
* 
* If your card is older then use x11-drivers/xf86-video-ati
* For migration informations please refer to:
* http://www.gentoo.org/proj/en/desktop/x/x11/ati-migration-guide.xml
* To switch to AMD OpenGL, run "eselect opengl set ati"
* To change your xorg.conf you can use the bundled "aticonfig"
* 
* If you experience unexplained segmentation faults and kernel crashes
* with this driver and multi-threaded applications such as wine,
* set UseFastTLS in xorg.conf to either 0 or 1, but not 2.
* 
* Fully rebooting the system after an ati-drivers update is recommended
* Stopping Xorg, reloading fglrx kernel module and restart Xorg
* might not work
* 
* Some cards need acpid running to handle events
* Please add it to boot runlevel with rc-update add acpid boot

I have the following AGP card

VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Park [Mobility Radeon HD 5430/5450/5470]
Audio device: Advanced Micro Devices [AMD] nee ATI Cedar HDMI Audio [Radeon HD 5400/6300 Series]

do I need to worry about this message or I should leave this message unattended?

any suggestion

share|improve this question
    
Try emerge -uDNav world then paste the output somewhere. My bet is you don't have X in the useflags. –  schaiba Aug 8 '13 at 21:14
    
Why not simply remove vlc (emerge --unmerge vlc) and try again? vlc could always be reinstalled later on... –  Amphiteóth Aug 8 '13 at 22:30

1 Answer 1

up vote 4 down vote accepted

Enable X USE-flag in either /etc/portage/make.conf or /etc/portage/package.use (e.i. echo "media-video/vlc X" >> /etc/portage/package.use).

Or maybe it's suitable for you to remove those two:

echo "media-video/vlc -qt4 -sdl" >> /etc/portage/package.use
share|improve this answer
    
Thanks a lot to all, I noticed that i had remove the X use flag from make.conf. so I added it and every thing works. –  user44499 Aug 10 '13 at 12:58
    
@user44499 If this answer did answer your question, please indicate so by upvoting and accepting. Thank you! –  Michael Kjörling Aug 10 '13 at 14:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.