Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

How do I run/install this: https://github.com/kevmoo/kbuild?

I installed the dependencies and tried to execute the bin/kbuild Python script, but it's giving me this error:

Traceback (most recent call last):
  File "kbuild/bin/kbuild", line 12, in <module>
    BREW_PREFIX = subprocess.check_output(['brew', '--prefix']).strip()
  File "/usr/lib/python2.7/subprocess.py", line 537, in check_output
    process = Popen(stdout=PIPE, *popenargs, **kwargs)
  File "/usr/lib/python2.7/subprocess.py", line 679, in __init__
    errread, errwrite)
  File "/usr/lib/python2.7/subprocess.py", line 1259, in _execute_child
    raise child_exception
OSError: [Errno 2] No such file or directory

My guess is that this tool was intended for OSX and Homebrew and that's why it's choking. I just wasn't sure based on the minimalist installation instructions.

share|improve this question
up vote 1 down vote accepted

Looking at the kbuild script it does appear to be OS X & brew specific.

excerpt from script

BREW_PREFIX = subprocess.check_output(['brew', '--prefix']).strip()
compiler_search_path = path.join(BREW_PREFIX, 'Cellar/closure-compiler', '*', 'libexec/build/compiler.jar')
compilers = glob.glob(compiler_search_path)

The homebrew directory on github would seem to lead credence to this too:

If you'd like to install kbuild via Homebrew:

brew install https://raw.github.com/kevmoo/homebrew-kevmoo/master/kbuild.rb


brew tap brew tap kevmoo/kevmoo brew install kbuild

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.