Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I currently have Debian 7.0 installed on my laptop (HP Pavilion dv9700). I would now like to install Arch instead. I wrote the Arch ISO to a USB drive, but when I start up my computer, it automatically loads to Debian.

I tried changing the boot order in the BIOS, but that didn't help, and there doesn't seem to be an option in the BIOS (PhoenixBIOS Setup Utility) to simply choose media to boot from. When setting USB Disk or USB diskette on key as the highest priority for booting, get the message "Remove disks or other media. Press any key to restart", which brings me to the GRUB loader when I remove the usb and press any key.

I found this which is for booting Xubuntu while having Ubuntu installed, but I don't know how I'd apply that to Arch and Debian. How would I go about booting from the USB?

share|improve this question
    
You shouldn't have to do anything special except setting a boot order in the BIOS that allows booting from USB. Are you sure your USB drive (we're talking about a pendrive right?) is good to go? Which utility did you use for making the drive? Pendrive linux? Are you sure it's in order? Sometimes the process will fail and that won't boot, whatever options are set afterwards. –  Amphiteóth Aug 7 '13 at 3:08

1 Answer 1

What method did you use to clone the ArchLinux ISO to your USB drive? The ISO is already 'hybridized' via isohybrid so you can just use dd.

In Debian, install qemu and test if the USB drive is bootable. qemu-system-i386 -hda /dev/sdX where 'sdX' is the USB drive.

You should also note that the ArchLinux LiveCD uses syslinux as its bootloader instead of GRUB.

Finally, if this is a one-time installer then you could use GRUB2's ISO boot and boot the LiveCD installer that way.

share|improve this answer
    
I was able to get an Arch Linux listing in the boot menu by following the ISO boot instructions. I also changed the img_dev location to dev/sdc1 (which I got from lsblk -f). However, I'm getting the following errors: error: no such partition. error: no such disk. error: you need to load the kernel first. It's also still asking me to remove my USB before I can get into the GRUB menu. –  Nic Aug 7 '13 at 4:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.