Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am trying to get a wireless connection on BackTrack 5 R3, but as soon as I boot up the BackTrack VM, the light on the adapter turns off. Drivers are installed and the VM detects the USB device. I am using an Asus N-13 wireless adapter to connect. It works fine on Ubuntu 12.10 (my host), and Windows 7. However, when I boot the BackTrack VM the adapter light goes off. Here is proof of drivers and USB detection.

lsusb

Bus 002 Device 002: ID 80ee:0021 VirtualBox USB Tablet
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 0b05:17ab ASUSTek Computer, Inc. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root h

ifconfig

eth0      Link encap:Ethernet  HWaddr 08:00:27:9c:d5:dc  
          inet addr:10.0.2.15  Bcast:10.0.2.255  Mask:255.255.255.0
          inet6 addr: fe80::a00:27ff:fe9c:d5dc/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:758 errors:0 dropped:0 overruns:0 frame:0
          TX packets:609 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:381917 (381.9 KB)  TX bytes:159317 (159.3 KB)
          Interrupt:10 Base address:0xd020 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:853 errors:0 dropped:0 overruns:0 frame:0
          TX packets:853 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:299027 (299.0 KB)  TX bytes:299027 (299.0 KB)

wlan0     Link encap:Ethernet  HWaddr 08:60:6e:cd:f8:2c  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lsmod

Module                  Size  Used by
nls_utf8               12493  1 
isofs                  39187  1 
vboxvideo              12511  1 
drm                   183453  2 vboxvideo
vboxsf                 38096  0 
dm_crypt               22236  0 
snd_intel8x0           33017  0 
8192cu                503302  0 
snd_ac97_codec        104623  1 snd_intel8x0
ac97_bus               12602  1 snd_ac97_codec
snd_pcm                72878  2 snd_intel8x0,snd_ac97_codec
snd_seq_midi           13132  0 
i2c_piix4              12983  0 
snd_rawmidi            24215  1 snd_seq_midi
snd_seq_midi_event     14076  1 snd_seq_midi
snd_seq                50403  2 snd_seq_midi,snd_seq_midi_event
snd_timer              23911  2 snd_pcm,snd_seq
snd_seq_device         13817  3 snd_seq_midi,snd_rawmidi,snd_seq
ppdev                  12840  0 
snd                    52787  7 snd_intel8x0,snd_ac97_codec,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
psmouse                72465  0 
serio_raw              13027  0 
joydev                 17161  0 
lp                     13321  0 
parport_pc             31867  0 
soundcore              12534  1 snd
snd_page_alloc         13709  2 snd_intel8x0,snd_pcm
vboxguest             190596  5 vboxsf
mac_hid                13037  0 
parport                34960  3 ppdev,lp,parport_pc
dm_mirror              21585  0 
dm_region_hash         15035  1 dm_mirror
dm_log                 17871  2 dm_mirror,dm_region_hash
aufs                  162169  0 
usbhid                 41119  0 
hid                    79842  1 usbhid
pcnet32                40553  0 

iwconfig

lo        no wireless extensions.

wlan0     unassociated  Nickname:"<WIFI@REALTEK>"
          Mode:Auto  Frequency=2.412 GHz  Access Point: Not-Associated   
          Sensitivity:0/0  
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

eth0      no wireless extensions.
share|improve this question
add comment

1 Answer

Try to connect with wireless using wicd it will help you.

to open it type this at terminal wicd &

or application --> internet -->wicd

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.