Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have a problem with my wireless connection, which drives me nuts.

I have been testing with two different wireless usb adapters, one based on the ar9271- and the other rtl8192su-chipset, but they both give same result.

The wireless usb adapters are connected to an open embedded linux kernel 2.6.32, running on a custom board with an ARM9 CPU.

The link is configured in adhoc-mode, and connected to an Windows 7 pc.

The problem is that I cannot transfer large files via the wifi link, I have testet with both Samba and vsftpd, but no difference.

I have testet the link using iperf (both TCP and UDP), successfully transferring about 5Gbytes of data. But if I try to transfer a file using samba or vsftpd the link drops within a minute (less than 20Mbytes).

When the connection drops it still seems "connected" in both ends, but nothing works, not even ping.

If I do an "iw wlan0 scan", the only station that appears is my own network.

I cannot find anything usefull in /var/log/ I tried dmesg, but that did not give anything either.

How do I debug this problem? I need to find out where and why in the wireless-stack the problem is caused.

UPDATE: If I run iperf with the -d option as suggested below, I get the describer problem. So it seems to have something to do with bidirectional data communication. In wireshark I see: TCP Retransmission, TCP Dup Ack

UPDATE: After the failure, if I do "iw wlan0 scan" only my own network appears...

share|improve this question
    
Does iperf in simultaneous bidirectional mode (-d) kill it as well? (When testing, make sure its actually doing bidirectional mode by looking at both TX and RX rates, I've had it lie to me sometimes...). Also, make sure you're running with a large enough window to get maximal data rates. –  derobert Aug 5 '13 at 19:57
    
Oh, also, how have you confirmed that the problem is one the Linux side? Have you tried a different adapter on the Windows machine? –  derobert Aug 5 '13 at 20:00
    
Can you run wireshark on the windows pc? –  ott-- Aug 5 '13 at 20:07
    
Update wireless driver and see if that helps. you can always use trace to see exactly is failing. –  Raza Aug 5 '13 at 20:11
    
I will try to run iperf with -d option, and change the Windows to a MacBook. But if this does not help (I'm not optimistic anymore ;-)), how do I debug the wireless stack? –  JakobJ Aug 5 '13 at 20:11
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.