Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

How do I permanently disable the GNOME screen reader ("Orca") on Debian Wheezy, without breaking GNOME?

I'm running Xfce.

Things I have tried, or looked at:

  • I found the command gsettings set org.gnome.desktop.a11y.applications screen-reader-enabled false on one site, and if I execute it in a terminal it seems to be respected (I get a spoken "goodbye" and subsequently setting it to true does not appear to do anything) but the next time I log in "welcome to Orca" is spoken again.

  • I edited /etc/xdg/autostart/orca-autostart.desktop to set NoDisplay=false but it still doesn't show up in Session and Startup under Application Autostart.

  • I had a look in dconf-editor which faithfully reports that the screen-reader-enabled value is set to false even on login to a new session. However, it still gets launched.

  • Another suggestion I saw was to use apt-get to remove the gnome-orca package entirely, but since gnome depends on gnome-orca, that would remove all of GNOME, which I do not want.

share|improve this question

3 Answers 3

up vote 3 down vote accepted

You can just get rid of the autostart file in /etc:

rm /etc/xdg/autostart/orca-autostart.desktop

ought to prevent it from starting. Files in /etc are for the administrator to edit or remove as he/she pleases, so this should not cause issues (other than, of course, any caused by orca not running).

Alternatively, you could uninstall the gnome meta-package, but keep all it dependencies except for orca. Though, on upgrade, you may not wind up with a "full" GNOME install if GNOME adds additional packages.

share|improve this answer
    
This by far feels like the safest solution. I was a little concerned about something not being happy around an upgrade about files installed through dpkg disappearing, but I'll face that if and when the issue comes up. It would have been nice if there was a clear distinction like in Apache's sites-available and sites-enabled, but this will do. :) –  Michael Kjörling Aug 2 '13 at 17:01
1  
@MichaelKjörling /etc is not "owned" by dpkg; it's owned by the admin. Packages are required to respect the admin's changes, including deleting files when that makes sense. See Debian Policy Manual, §10.7.3 –  derobert Aug 2 '13 at 19:11

I can suggest a very crude solution: just to kill .session file in Dbus, so that no other application can activate orca. Try either removing or commenting out the respective .session file in /usr/share/dbus-1/services.

Well, after thinking for a while, you'd better not. Orca seems to make use of at-spi, its services correspond to these entries in the per-session instance of Dbus:

org.a11y.atspi.Registry.service                                
org.a11y.Bus.service  

http://www.linuxfoundation.org/collaborate/workgroups/accessibility/atk/at-spi/at-spi_on_d-bus

If you were using Gnome, you could've just turned Accessibility off in System Settings -> Accessibility -> Screen Reader.

share|improve this answer

To preface my solution, I removed the aforementioned autostart file, but orca still ran during gdm login sessions.

Using ps -ef | grep orca, I traced the original process that started orca every time gdm was initiated. To keep things short and sweet, the fix is to comment out the following file:

/usr/share/gdm/greeter/autostart/orca-autostart.desktop

Hope this helps.

share|improve this answer
    
Welcome to Unix & Linux Stack Exchange! If you have a NEW question, please ask it by clicking the Ask Question button. If you have sufficient reputation, you may upvote the question. Alternatively, "star" it as a favorite and you will be notified of any new answers. –  slm Oct 28 '13 at 23:55
    
@slm I had the same reaction at first, seeing the notice in my email inbox. But there's an answer now. :) (Though I'm not sure exactly what "comment out the following file" means. user50146, would you care to elaborate on that?) –  Michael Kjörling Oct 29 '13 at 8:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.