Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have a strange problem with my rhel 6.4 system. If I do a rlogin to any of my machines, all the files in the remore machine will be flashing and it is so annoying. Can somebody please tell me how can I disable this?

share|improve this question
    
A file is an invisible collection of bits on a disk. It could not possibly flash. Perhaps you mean some other flashy things, like file names as shown by ls in the terminal. –  n.m. Aug 1 '13 at 20:15
    
ya... the files which are listed after the ls command are flashing. –  stany Aug 1 '13 at 20:17

1 Answer 1

up vote 6 down vote accepted

There are several reason why the output of ls would blink. Here are some, roughly in a decreasing order of probability.

  1. Your $LS_COLORS environment variable is set incorrectly.
  2. Your $LS_COLORS environment variable is not set and your /etc/DIR_COLORS file is corrupt.
  3. Your $TERM environment variable is set incorrectly.
  4. All your files are in fact orphaned symbolic links.

A reasonably set $LS_COLORS should contain substrings like or=01;05 and mi=01;05 and there should be no more 05s. Likewise, a reasonable /etc/DIR_COLORS should contain 05 in two places, near words ORPHAN and MISSING.

These settings make sure that ls shows just orphaned symbolic links, and missing files they point at, in blinking characters. 05 or 5 is the ANSI terminal escape code for blinking.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.