Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

After I did:

route add default gw 192.168.7.1

I also changed /etc/resolv.conf:

nameserver 192.168.7.1

in order to share internet between Ubuntu in VMware. I've got internet working but after a reboot, I can never ssh to beaglebone from any host. (Win7 or Ubuntu). SSH doesn't return any message back.

On beagblebone the default is nameserver 127.0.0.1. Also, the command route returns:

Destination     Gateway     mask             Flags  Ref  Use  Iface
192.168.7.0     0.0.0.0     255.255.255.252  U      0    0    usb0

ifconfig returns:

usb0 net addr:192.168.7.2 Bcast:192.168.7.3

On the host(win7):

ipv4 addr: 192.168.0.110, ipv4 default gw 192.168.0.1

on Ubuntu ifconfig returns:

etho 192.168.179.129 Bcast:192.168.179.255

I also disabled GNOME from start up maybe it shuts down some default configurations? The file resolv.conf resets every time when the system starts.

share|improve this question
add comment

1 Answer

up vote 3 down vote accepted

Beaglebone seems to have a very small network 192.168.7.0/30. (note: 192.168.7.2 Bcast:192.168.7.3) which means it will only see .1 and .2 on the "local network" (.0 is the network address and .3 is the broadcast). It also has no default route so will not route anything outside of those two addresses.

The win7 host I assume will be on the 192.168.0.0/24 network (with a netmask of 255.255.255.0) and a default gateway of 192.168.0.1 (though nothing you mention in your setup has the 192.168.0.1 address?).

Ubuntu is on its own /24 segment, 192.168.179.0/24 (note the broadcast of 192.168.179.255).

Unless 192.168.0.1 has visibility of the routes of the two seperate segements 192.168.7.0/30 (beaglebone's) and 192.168.0.0/24 you are not going to be able to get from win7 to beaglebone. A similar issue may be present with Ubuntu depending on what routing/default route it has in place.

You've not provided routing for either win7 or ubuntu, which would help give a clearer picture of what your routing setup is. (You can provide those details by running a netstat -rn on those hosts).

Also what is is physically connected to what? Is ubuntu a VM, or is it a separate host? Do they both plug into beaglebone, or all three connected to some other device (the host at 192.168.0.1?)

As to to your resolv.conf changing, that is most likely due to the fact that your IP address is probably obtained via DHCP (which will replace the resolv.conf with what it gets from the DHCP ACK response from the DHCP server). You can edit your dhclient.conf and either add a prepend domain-name-servers 127.0.0.1; statement or by adding a interface declaration that does not contain a domain-name-servers statement.

share|improve this answer
    
SO the beaglebone is connected to a host Win7. It can also be connected to ubuntu inside of VM on that Win7. Sharing internet through USB is such a pain and I don't want to do it again. It's working after reflashing the image. Here is the default configuration just for reference: dropbox.com/s/vhql35qgrtizfpy/beagleboneB_net_settings.JPG –  Timtianyang Aug 1 '13 at 5:43
    
here is the settings on win7:dropbox.com/s/q2p2u2fd5n6pfbu/host_settings.JPG I wonder why it doesn't show default gateway –  Timtianyang Aug 1 '13 at 5:44
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.