Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have a Broadcom wireless chip which I've managed to wrestle into working with Debian GNU/Linux (I'm on Sid, if it matters). The interface is definitely there:

612 ± ip link    
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP mode DEFAULT qlen 1000
    link/ether 3c:07:54:06:e0:86 brd ff:ff:ff:ff:ff:ff
3: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DORMANT qlen 1000
    link/ether e4:ce:8f:40:ec:c4 brd ff:ff:ff:ff:ff:ff
alex-debian ओम् ~:(14h55m|git@master)
613 ±  

I have GNOME, and hence NetworkManager, up and running. When I look at GNOME Control Center in the Network pane, the Wireless tab gives information but doesn't list any wireless networks. I've tried connecting to a hidden network, just in case, but this didn't work. I know my network isn't hidden.

Edit: per this wiki page, I've added myself to the netdev group, and relogged into my session, with no result.

How can I start diagnosing the source of this problem?

share|improve this question
add comment

2 Answers 2

I'd double check using iwlist wlan0 scan from the terminal to see if the device wlan0 can see access points:

$ iwlist wlan0 scan | grep -v IE:
wlan0     Scan completed :
          Cell 01 - Address: 34:12:AB:12:C4:4D
                    Channel:6
                    Frequency:2.437 GHz (Channel 6)
                    Quality=58/70  Signal level=-52 dBm  
                    Encryption key:on
                    ESSID:"none_of_your_business"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
                    Mode:Master
                    Extra:tsf=00000477a0ba1234
                    Extra: Last beacon: 71963ms ago
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK

I would also open a terminal window and tail the /var/log/syslog while you restart NetworkManager:

$ sudo tail -f /var/log/syslog

Then restart NetworkManager:

$ service NetworkManager restart

I'd also make sure that the Linux Kernel detected the WIFI device correctly by reviewing the dmesg log:

$ dmesg
share|improve this answer
    
turned out it was because I was using WEP, but props for the detailed answer. upvoted. –  strugee Jul 28 '13 at 23:54
add comment
up vote 0 down vote accepted

The wireless network was using WEP, which as stated by the wiki page in the question, is unsupported. I assumed that this meant "will work but have weird problems", but in fact, upgrading the firmware, then using the new options to switch to WPA2 solved my problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.