Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I managed to get russian language working in my Gnome apps, but neither in the console (Alt-Shift-F2 and such) nor in the Gnome Terminal

valyagentoo va1en0k # locale
LANG=ru_RU.UTF-8
LC_CTYPE="ru_RU.UTF-8"
LC_NUMERIC="ru_RU.UTF-8"
LC_TIME="ru_RU.UTF-8"
LC_COLLATE="ru_RU.UTF-8"
LC_MONETARY="ru_RU.UTF-8"
LC_MESSAGES="ru_RU.UTF-8"
LC_PAPER="ru_RU.UTF-8"
LC_NAME="ru_RU.UTF-8"
LC_ADDRESS="ru_RU.UTF-8"
LC_TELEPHONE="ru_RU.UTF-8"
LC_MEASUREMENT="ru_RU.UTF-8"
LC_IDENTIFICATION="ru_RU.UTF-8"
LC_ALL=ru_RU.UTF-8


valyagentoo va1en0k # cat /etc/conf.d/consolefont 
# /etc/conf.d/consolefont

# CONSOLEFONT specifies the default font that you'd like Linux to use on the
# console.  You can find a good selection of fonts in /usr/share/consolefonts;
# you shouldn't specify the trailing ".psf.gz", just the font name below.
# To use the default console font, comment out the CONSOLEFONT setting below.
# This setting is used by the /etc/init.d/consolefont script (NOTE: if you do

CONSOLEFONT="UniCyr-sans"

# CONSOLETRANSLATION is the charset map file to use.  Leave commented to use
# the default one.  Have a look in /usr/share/consoletrans for a selection of
# map files you can use.

# CONSOLETRANSLATION="8859-1_to_uni"
share|improve this question
add comment

3 Answers 3

Here are some of my suggestions:

  • Have you enabled the unicode useflag? Without it zsh won't be compiled with Unicode support. If you're using bash, it should have Unicode support through libreadline. Also, ksh and tcsh don't support Unicode at all.
  • It could also be your locale or font selections, but they look fine from what I can gather. Just make sure to list your locale in /etc/locale.gen and generate it with locale-gen on the command line.

Also, take a look at the Using UTF-8 with Gentoo guide from the Gentoo documentation.

share|improve this answer
1  
for bash, USE="net nls -afs -bashlogger -examples -mem-scramble -plugins -vanilla". I generated the locale, dont work yet. And I think I did all steps from the guide, I'll try to reboot now –  valya Mar 2 '11 at 17:12
1  
As far as I know bash uses sys-apps/readline, which has Unicode support by default (no USE flag to toggle it on/off, it's always on). So I guess that should work. –  Cedric Mar 2 '11 at 19:45
add comment

Have you tried change consolefont to another value? I had the same problem and

    consolefont="cyr-sun16"

works fine for me.

share|improve this answer
add comment
$ emerge terminus-font corefonts cronyx-fonts freefonts
$ nano /etc/locale.gen
<<enter this>>
ru_RU.UTF-8 UTF-8
$ nano  /etc/conf.d/consolefont
<<enter this>>
CONSOLEFONT="cyr-sun16"
$ nano /etc/env.d/02locale
<<enter this>>
LC_ALL=""
LANG="ru_RU.UTF-8"LC_ALL=""
LANG="ru_RU.UTF-8"
$ locale-gen 
$ /etc/init.d/consolefont restart
$ env-update 
$ source /etc/profile
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.