Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm having trouble getting Ubuntu connected to the internet in vmware fusion. Every other Linux distro has no trouble...

ifconfig shows that eth0 is up and running, has been assigned an ipv4 address (DHCP) as well as an ipv6 address. I can ping localhost, but nothing else. It just stalls out. I'm running vmware in NAT (as opposed to bridged) mode, which has worked fine for all other distros I've tried (Debian, BackTrack, openSuse...). I thought Ubuntu was supposed to be ridiculously easy to work with? Seems a lot of people have had this problem, but no clear answers yet.

Thanks in advance for any guidance!

share|improve this question
1  
This might help: unix.stackexchange.com/q/8118/8123#8123 –  Tshepang Mar 2 '11 at 13:14
    
Thanks, this is a great post. –  Richard Calahan Mar 2 '11 at 13:25
    
Probably more appropriate for askubuntu.com –  tjameson Jul 1 '11 at 4:55

1 Answer 1

Well, my previous assumptions were wrong. I've always read that you should run Linux under NAT in vmware, but I switched to bridged mode and now everything works. My ip address in the virtual machine is now the same as my ip address on the main machine. Hope this little tidbit of info helps someone...

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.