Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm trying to install pyside from source on Fedora 19. Running sudo python setup.py bdist_egg --version=1.2.0 --qmake=/usr/lib64 gives:

HEAD is now at 92062bc... Version bump to 0.2.14
Checking out submodule pyside-examples to branch master
Running process: git checkout master
Already on 'master'
Removing /home/andreas/pyside-setup/pyside_package
running bdist_egg
running build
Python architecture is 64bit
error: Permission denied

And without sudo:

Traceback (most recent call last):
  File "setup.py", line 228, in <module>
    rmtree(d)
  File "/home/andreas/pyside-setup/utils.py", line 280, in rmtree
    shutil.rmtree(dirname, ignore_errors=False, onerror=handleRemoveReadonly)
  File "/usr/lib64/python2.7/shutil.py", line 247, in rmtree
    rmtree(fullname, ignore_errors, onerror)
  File "/usr/lib64/python2.7/shutil.py", line 256, in rmtree
    onerror(os.rmdir, path, sys.exc_info())
  File "/home/andreas/pyside-setup/utils.py", line 276, in handleRemoveReadonly
    os.chmod(path, stat.S_IRWXU| stat.S_IRWXG| stat.S_IRWXO) # 0777
OSError: [Errno 1] Operation not permitted: '/home/andreas/pyside-setup/pyside_package/PySide'
share|improve this question
    
Do /home/andreas/pyside-setup/pyside_package/PySide has the executable bit? –  Braiam Jul 25 '13 at 17:38
    
What is the executable bit? What do you mean? –  Armin Meisterhirn Jul 25 '13 at 20:06
    
"Software and software installers in GNU/Linux need to be marked as 'executable' in order to be treated as runnable programs." You can do so using chmod u+x file –  Braiam Jul 25 '13 at 20:08
    
Thanks.That's indeed the solution. –  Armin Meisterhirn Nov 2 '13 at 3:58
add comment

1 Answer

Since the /home/andreas/pyside-setup/pyside_package/PySide has not the executable bit, you should set it up. This allows the script to be executed:

chmod u+x /home/andreas/pyside-setup/pyside_package/PySide

Should allow the execution. Any "executables" files needs this bit or Linux will prevent you from executing. This is one of the security measures of Linux.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.