Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have an HP Envy dv7 with a dual boot setup of Win 8 and Fedora 18. On 07/22/2013 I updated all packages in Fedora 18 that had updates available.

After a reboot, Fedora is now detecting that a second monitor is connected on the vga-2 port (according to xrandr) but I don't have a second monitor. Is there a way to prevent it from detecting this monitor?

Edit:

Thanks for the suggestion below @slm however that just gave me a blank screen. While working on that solution I realized that there is a new grub menu entry. I compared it to the old menu entry and the only difference is the kernel version. If I log in with the old version the problem isn't there but if I use the new version it is.

If I run xrandr with the old kernel I get the following:

Screen 0: minimum 320 x 200, current 1600 x 900, maximum 8192 x 8192
LVDS1 connected 1600x900+0+0 (normal left inverted right x axis y axis) 382mm x 215mm
   1600x900       60.0*+   40.0  
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
VGA1 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)
VGA-2 disconnected (normal left inverted right x axis y axis)

However if I run it under the new kernel I get:

Screen 0: minimum 320 x 200, current 1600 x 900, maximum 8192 x 8192
LVDS1 connected primary 1600x900+0+0 (normal left inverted right x axis y axis) 382mm x 215mm
   1600x900       60.0*+   40.0  
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
VGA1 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)
VGA-2 connected (normal left inverted right x axis y axis)
   1024x768       60.0  
   800x600        60.3     56.2  
   848x480        60.0  
   640x480        59.9  
  1024x768 (0x63)   65.0MHz
        h: width  1024 start 1048 end 1184 total 1344 skew    0 clock   48.4KHz
        v: height  768 start  771 end  777 total  806           clock   60.0Hz
  800x600 (0x64)   40.0MHz
        h: width   800 start  840 end  968 total 1056 skew    0 clock   37.9KHz
        v: height  600 start  601 end  605 total  628           clock   60.3Hz
  800x600 (0x65)   36.0MHz
        h: width   800 start  824 end  896 total 1024 skew    0 clock   35.2KHz
        v: height  600 start  601 end  603 total  625           clock   56.2Hz

Not sure what's causing this but since I can still use the old kernel, I'll just do that and see if Fedora pushes out an update that fixes it. Thanks again for the help.

share|improve this question
    
Please provide output from xrandr. Edit your question and add it there please. –  slm Jul 25 '13 at 1:52

2 Answers 2

I came across this potential workaround. Add the following to your grub2 boot loader kernel parameters. Edit the file, /boot/grub2/grub.cfg:

linux /vmlinuz-… video=LVDS-1:d

Also you can use xrandr to enable/disable the different devices you have connected manually.

$ xrandr 
Screen 0: minimum 320 x 200, current 1440 x 900, maximum 8192 x 8192
LVDS1 connected 1440x900+0+0 (normal left inverted right x axis y axis) 303mm x 190mm
   1440x900       60.0*+   50.0  
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
VGA1 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)
HDMI2 disconnected (normal left inverted right x axis y axis)
HDMI3 disconnected (normal left inverted right x axis y axis)
DP2 disconnected (normal left inverted right x axis y axis)
DP3 disconnected (normal left inverted right x axis y axis)

To turn off LVDS1:

$ xrandr --output LVDS1 --off

I'd also try this:

$ xrandr --auto

It should disable any enabled outputs that are disconnected, i.e. your mysterious 2nd monitor.

share|improve this answer

I was also seeing an extra monitor while taking screenshots or screencasting. xrandr method explained above didn't worked for me. I Used the GUI approach.Went to Display Settings -> chose the second monitor and turned it off. The monitor is still shown in the Display Manager but it doesn't seem to affect screencasting etc.Turning off the Unknown display

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.