Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I copied my ~/.emacs file from ubuntu linux; I've installed Consolas font (and it works in gnome terminal, and as a default Monospace font); but Emacs does not see it

(custom-set-faces '(default ((t (:inherit nil :stipple nil :background "white" :foreground "black" :inverse-video nil :box nil :strike-through nil :overline nil :underline nil :slant normal :weight normal :height 98 :width normal :foundry "microsoft" :family "Consolas"))) t))

That's how I set the font in emacs, but it does not work (It worked and still works in Ubuntu)

What can I do?

Font select menu (menu-set-font, I guess) looks very strange, consists of three options: Misc, Courier and Fontset, and there are no sign of my system fonts

share|improve this question
add comment

2 Answers

up vote 4 down vote accepted

As Gilles said, to use a TrueType font like Consolas in Emacs 23 you must link it with the Freetype and Fontconfig libraries. In Gentoo, you do that by turning on the xft use flag when building Emacs. You'll need to turn that flag on (either globally or just for app-editors/emacs) and reinstall Emacs.

share|improve this answer
    
thanks! awesome! looking into USE flags solved not only this problem with emacs, thank you very much –  valya Mar 2 '11 at 0:21
1  
@valya, because it builds things from source and provides use flags, Gentoo is much more customizable than distros like Ubuntu. The downside is that it's easy to leave out a feature that it turns out you actually do want. Fortunately, that's usually not too hard to fix; you just adjust your use flags and reinstall whatever program is missing a feature. –  cjm Mar 2 '11 at 0:47
    
It's okay then the app is small, but I sometimes had to leave my computer building (or re-building) certain things while I'm asleep, because it took hours –  valya Mar 2 '11 at 13:53
add comment

Support for TrueType fonts such as your Consolas font — more generally, support for client-rendered fonts — requires Emacs to be compiled against the Freetype and Fontconfig libraries. This was introduced in Emacs 23. Before, only traditional, server-rendered fonts were supported. See the Emacs manual for more information about the two kinds of fonts and how to use them.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.