Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have an old Medion MD 8818 desktop PC with MS-7318 mobo with Phoenix AwardBIOS 6.00PG.

I'm attempting to run Zorin OS 7 Core on it, but the PC won't boot my 32GB Sandisk Cruzer Switch USB stick that I prepared using Universal USB Installer and the Zorin ISO.

The BIOS auto-recognizes and lists the stick as a removable device, and I've specified removable device as first boot option. During boot, I see the stick listed before my (SATA) HDD, but it won't boot.

Using Trinity Rescue Kit 3.4 in the single drive connected to the end of an IDE cable, I can copy files between the stick and my HDD.

Prepping the stick with other things like FreeDOS and attempting to boot from floppy using a FreeDOS DVD also gives me the "isolinux: Disk error 01, AX=0201, drive 80" error, which should be coming from the stick as the HDD only has Windows (of which I renamed bootmgr to keep it from booting) and I believe FreeDOS doesn't use isolinux.

Why am I getting this error? I fear it might be my BIOS, despite it apparently recognizing the stick, as I've read terrible things about updating a BIOS from a DVD.

share|improve this question
    
Can you check the Zorin ISO with md5 to make sure you have a good download? If so, I'd try with a different USB stick. I personally don't think the BIOS is faulty here. –  schaiba Jul 20 '13 at 14:52
    
The MD5 is correct. This Toshiba 8GB USB stick is recognized by Windows 7 as removable drive. The Sandisk was recognized as local drive. One of these machines is wrong. I'll manually try the Sandisk as HDD on the Medion again. –  Cees Timmerman Jul 20 '13 at 16:50
    
Setting the Sandisk 32GB USB stick as HDD instead of auto-detected FDD mode worked. I guess that old BIOS was mistaken. –  Cees Timmerman Jul 20 '13 at 17:04
    
TDK, rather than Toshiba. Also, the BIOS doesn't like to boot FDD sticks. –  Cees Timmerman Jul 23 '13 at 20:12
add comment

1 Answer

up vote 1 down vote accepted

Setting the Sandisk 32GB USB stick as HDD instead of auto-detected FDD mode worked. I guess that old BIOS was mistaken. Unfortunately the BIOS update only runs in Windows. (Should i try it in Zorin?)

Windows 7 recognized the USB stick as local drive correctly, it turns out. Weird.

share|improve this answer
    
Setting the Removable Media Bit to 0 allows Windows to see all partitions. –  Cees Timmerman Jul 21 '13 at 21:39
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.