Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Currently I can't use my eclipse project. I'm using ArchLinux:

                   -`
                  .o+`                 rkmax@satellite
                 `ooo/                 OS: Arch Linux 
                `+oooo:                Kernel: x86_64 Linux 3.9.9-1-ARCH
               `+oooooo:               Uptime: 1h 19m
               -+oooooo+:              Packages: 922
             `/:-:++oooo+:             Shell: bash
            `/++++/+++++++:            Resolution: 3286x1200
           `/++++++++++++++:           DE: Gnome 3.8.2
          `/+++ooooooooooooo/`         WM: Not Found
         ./ooosssso++osssssso+`        WM Theme: Not Found
        .oossssso-````/ossssss+`       GTK2 Theme: Adwaita
       -osssssso.      :ssssssso.      GTK3 Theme: Adwaita
      :osssssss/        osssso+++.     Icon Theme: Faenza-Darkest
     /ossssssss/        +ssssooo/-     Font: Ubuntu 10
   `/ossssso+/:-        -:/+osssso+-   CPU: Intel Core i3 CPU M 380 @ 2.533GHz
  `+sso+:-`                 `.-/+oso:  RAM: 1049MB / 2808MB
 `++:.                           `-/+/  
 .`                                 `/

java version "1.7.0_40"
OpenJDK Runtime Environment (IcedTea 2.4.1) (ArchLinux build 7.u40_2.4.1-1-x86_64)
OpenJDK 64-Bit Server VM (build 24.0-b50, mixed mode)

Eclipse Juno 4.2 (extra/eclipse 4.2.2-1)

The problem here is when I try to change anything in my project and eclipse goes to rebuild it. A process systemd-coredum eats all memory:

COMMAND                   %MEM    RSS     %CPU
systemd-coredum           54.4    1528.04 4.3
java                      9.7     272.48  69.6
chromium                  4.6     130.08  2.2
chromium                  2.1     61.12   2.9
chromium                  2.1     60.67   0.7
gnome-shell               1.7     49.16   6.4
banshee                   1.5     42.80   4.2
chromium                  1.3     37.28   0.2
chromium                  0.8     23.45   0.2
pulseaudio                0.3     10.65   2.0

I have ulimit -c unlimited in .bashrc file and a symlink in the coredump conf

$ ln -s /dev/null /etc/sysctl.d/coredump.conf
$ systemctl restart systemd-sysctl

But I can't solve this issue.

share|improve this question
add comment

1 Answer

To stop the coredump you can disable it by limiting it's resources to 0:

$ ulimit -c 0

Check out this thread on the ArchLinux forums, looks to be an active problem as of 7/2013, https://bbs.archlinux.org/viewtopic.php?id=154511. The thread had a couple of posts that mentioned the ln -s /dev/null ... method as no longer working.

This wiki article titled: systemd in the ArchLinux wiki had additional details.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.