Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have one of my Ubuntu machine-

rkost@rj-vm9-14105:~/infinispan/infinispan-server-6.0.0.Alpha1/bin$ uname -a

Linux rj-vm9-14105 2.6.35-22-server #33-Ubuntu SMP Sun Sep 19
20:48:58 UTC 2010 x86_64 GNU/Linux

how do I make sure multicast is enabled on my network interfaces and infrastructure?

I have tried several solutions but not able to understand whether it is actually enabled or not. I am trying to start the Infinispan server as the remote cache on both of my machines but somehow they are not able to form a cluster of two nodes so I am suspecting multicast feature is disabled somehow.

share|improve this question

2 Answers 2

The default is that multicast is enabled.

You can force it on or off with ifconfig.

On:

ifconfig eth0 multicast

Off:

ifconfig eth0 -multicast

To check which multicast groups are subscribed:

netstat -g

I don't see a control for multicast in NetowrkManager so if you need to force it on or off the simplest, least effort method would be to add the appropriate command to /etc/rc.local.

share|improve this answer
    
It looks like I have Multicast enabled. But the problem that I am facing is whenever I start Infinispan server, they are not able to form cluster. So that means somehow they are not able to communicate with each other bcoz of this Multicast. Does it listen on some port? Something like that I need to make sure of? –  Webby Jul 19 '13 at 21:43

To check if multicast is enabled on the interface do a "ifconfig eth0" and look for: MULTICAST

share|improve this answer
    
it might be worth noting that just because it's enabled, doesn't mean it's subscribed to any addresses. –  hbdgaf Jul 19 '13 at 20:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.