Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I tried to install gnome2 in FreeBSD using the command pkg_add -v -r gnome2. I also edited my file in /etc/rc.conf and added the lines gdm_enable="YES" and gnome_enable="YES" and also added the lines in /etc/fstab proc /proc procfs rw 0 0 . Still I typed startx in my prompt it gave me error for command not found. Please Help.

share|improve this question

1 Answer 1

If you intend to use gdm, you don't need startx (if you really want it, you need to install the x11/xinit port to get it). gdm is a graphical login manager, whereas startx is used to begin an X session from the command line.

Although you have edited your system configuration files as instructed, you now need to either reboot the system so that the normal startup process can mount the procfs file system and start up all the services that GNOME requires, or you can do it by hand:

sudo mount -at procfs
sudo service dbus start
sudo service avahi-daemon start
sudo service avahi-dnsconfd start
sudo service hald start
sudo service gdm start

(The presence of gnome_enable in your /etc/rc.conf file causes these services to be run automatically at startup.)

share|improve this answer
    
I have gdm installed so that means I dont have to now install x11/xinit right? –  Tarun Jul 19 '13 at 13:19
    
while starting gdm it gives a warning stating "WARNING **: Failed to acquire org.gnome.DisplayManager" and "WARNING **: Could not acquire name; bail out" also "host name not found: 2.freebsd.pool.ntp.org" any help? –  Tarun Jul 19 '13 at 13:24
    
Is name resolution working correctly on your system? Is the machine properly connected to the Internet? On the command line, try host 2.freebsd.pool.ntp.org and see what you get. And no, you don't need to install xinit if you want to use gdm –  D_Bye Jul 19 '13 at 13:40
    
No my machine is not connected to the internet. can that be the problem causing it? –  Tarun Jul 19 '13 at 13:47
    
Yes, that is exactly what is causing the DNS failure. Is connecting this machine an option? –  D_Bye Jul 19 '13 at 13:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.