Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I just did a Gentoo fresh install but when I boot it the root filesystem mounts as read only. Once I login I can remount it with mount -o remount,rw / but it's not even recognizing my hostname. Someone on irc told me it could be that for some reason fsck bombs as root is always mount ro first and then fsck remounts it rw.

I found someone having the same problems and I tried what he did but it didn't work for me Root file system is mounted read-only on boot on Gentoo Linux

This is my fstab.

EDIT I already fixed it, it was a problem with an option not enabled in the kernel

Pseudo Filesystems --->
        [*] Virtual memory file system support (former shm fs)
share|improve this question
    
Kind of a long shot because you can remount rw, but does dmesg mention IO errors? –  Halfgaar Jul 19 '13 at 10:58
1  
Are you seeing any errors on boot? What does the output of blkid look like? –  Patrick Jul 20 '13 at 6:13
    
Please add the solution as answer, and accept it, so everyone knows your problem is solved. –  Risto Salminen Nov 24 '13 at 15:30
add comment

1 Answer

up vote 1 down vote accepted

I found this solution over on SuperUser titled: Root file system is mounted read-only on boot on Gentoo Linux, which sounds exactly like your issue. The solution was to make sure that the root service was enabled in your boot runlevel. These are the services that were suggested as needing to be started in the boot runlevel:

bootmisc
consolefont
device-mapper
dmcrypt
fsck
hostname
hwclock
keymaps
localmount
modules
net.lo
netmount
network
procfs
root
svscan
swap
sysctl
sysfs
termencoding
urandom
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.