Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm using putty > screen > vim, and screen is sending the same sequence for Ctrl+Right and Right in application mode for vim.

There is an option to make putty send the cursor mode sequences (disable application cursor keys mode) when in application mode and that works, but when screen is introduced, something isn't right.

How would I go about fixing this?

share|improve this question

1 Answer 1

If I set term = xterm in putty, and term=putty in screenrc, it seems to work.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.