Sign up ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. It's 100% free, no registration required.

I've tried: gksudo gedit /etc/xinetd.d/tftp (this is the path I need). I got an error message:

couldn't find the file /etc/xinetd.d/tftp
please check that you typed the location correctly and try again

What do I need to do?

share|improve this question

2 Answers 2

My version of gedit (2.22.3) does create the file if it doesn't exist. If yours doesn't, you can create the file first with sudo touch /etc/xinetd.d/tftp.

I recommend using sudoedit /etc/xinetd.d/tftp instead. This uses your favorite editor, taken from the EDITOR environment variable, or a system default if you haven't expressed your preference. Add export EDITOR=/usr/bin/gedit to your ~/.profile if necessary.

See also How do I run a command as the system administrator (root).

share|improve this answer

I made a new launcher for my desktop (I installed gnome desktop fallback) by gnome-desktop-item-edit --create-new ~/Desktop. then typed in as the run command: gksu nautilus that runs as root.

navigated to my regular home that logs in show hidden files went inside Templates folder, made new file and newfile.php and newfile.html I also edited those files and put in my code I usually create with.

then I copied the Templates file and navigated to "root' home the paste it there (the folder is missing) now when I run nautilus as root I can create my files as well as the untittled with no extention. then edit with gedit using the nautilus I launched as root with my new launcher (gksu nautilus)

Ubuntu 14.01LTS

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.