Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have a Thinkpad T431s with trackpoint (the red stick in the middle of the keyboard) and clickpad (a touchpad that also acts as a button). This is the first model that does not provide any dedicated buttons for the trackpoint. I want to use the trackpoint only. So far I'm able to configure the clickpad such that it acts as buttons for the trackpoint while disabling motion via:

# Devide the clickpad into 3 areas for left/middle/right click
xinput set-prop 10 "Synaptics Soft Button Areas" 3477, 5112, 0, 0, 2659, 3476, 0, 0

# Disable mouse movements
xinput set-prop 10 "Device Accel Constant Deceleration" 9999999

# Disable tap events
xinput set-prop 10 "Synaptics Tap Action" 0, 0, 0, 0, 0, 0, 0

where 10 is the ID of the clickpad.

However, I can't figure out how to configure the trackpoint to use the middle button for scroll emulation. The problem seems to be that the trackpoint device does not have any real buttons. Thus the following does not work:

xinput set-prop "TPPS/2 IBM TrackPoint" "Evdev Wheel Emulation" 1
xinput set-prop "TPPS/2 IBM TrackPoint" "Evdev Wheel Emulation Button" 2

Is there any way configure the trackpoint to use the middle button of another device (the clickpad) for scroll emulation? Any other suggestions?

share|improve this question
    
Did the answer I provide you help at all? –  slm Aug 5 '13 at 1:55
    
Thank your for your answer and sorry for the delayed response. I haven't got a notification.In fact the solution you propose is not really what I am looking for. I basically want to disable the touchpad and use the trackpoint with 3 buttons and scroll emulation for the middle button. The solution you have posted does only provide a reasonable configuration of the touchpad with clickpad functionality. –  abird Aug 13 '13 at 19:14
    
NP - Can you try cleaning up your question so that the terms are better defined? Reading through it I'm getting confused whether you're talking about the red stick (trackpoint device) or the trackpad (square at the bottom). On my T420 they both have buttons, on yours jus the trackpoint device has buttons, correct? Also I think your trackpad can act as a touchpad too? –  slm Aug 13 '13 at 19:32
    
OK. Now I only use the terms trackpoint and clickpad and give a short explanation at the beginning. The T431s does not provide any real buttons neither for the trackpoint nor for the clickpad. The only "button" is the clickpad itself. My problem is that I can't use the clickpad button event to trigger scroll emulation on the trackpoint device. –  abird Aug 13 '13 at 19:58
add comment

3 Answers 3

up vote 1 down vote accepted

For some linux distributions there is already a patched version of the evdev driver that supports scrolling with the TrackPoint while pressing the region configured as "center button" of the clickpad.

On Arch, this is the AUR package: https://aur.archlinux.org/packages/xf86-input-evdev-trackpoint/ I have tried it on a T440s and works perfectly out-of-the-box.

If you use a different distro you can search for a patched evdev driver, try to patch it and compile it yourself with the diff provided in the tar.gz file on the AUR site (ATM patches the vanilla 2.8.2 evdev driver from freedesktop.org), or switch to Arch and use the AUR package directly ;)

share|improve this answer
    
That looks very promising, thank you! I will try to get this thing to run on my Ubuntu box. Also I will rethink my distribution choice :) –  abird Jan 7 at 11:36
add comment

I have a t440 and have the same issue. My solution was to leave the touch pad active, but to exclude the area were I defined the SoftButtonAreas from being active (so the cursor doesn't move when I click). I enabled horizontal and vertical two-finger scrolling, which is easy enough to do with my thumbs while my fingers remain on the keyboard.

Follow these instructions to set up your xorg.conf

sudo mkdir /etc/Xll/xorg.conf.d
sudo vim touchpad.conf

paste the text below

  Section "InputClass"
          Identifier "SynPS/2 Synaptics TouchPad" 
          matchIsTouchpad "yes"
          Driver    "synaptics"                 
          Option    "AreaTopEdge"   "2235"
          Option    "AreaBottomEdge"  "0"
          Option    "AreaRightEdge"   "0"
          Option    "AreaLeftEdge"  "0"
          Option    "SoftButtonAreas"   "3874 0 0 2235  2673 3873 0 2235"
          Option    "RBCornerButton"    "1"
          Option    "VertTwoFingerScroll"    "1"
          Option    "HorizTwoFingerScroll"    "1"
 EndSection 
share|improve this answer
    
This is kind of what I'm doing right now (although I completely disabled the mouse movement of the pad by setting a very high deceleration). However, I really like to have the middle-button wheel emulation. There seems to be a bug in the evdev driver (bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-evdev/+bug/…). –  abird Dec 20 '13 at 11:08
add comment

Came across this post on AskUbuntu. The Q&A is titled: Ubuntu 12.04.2 on a Lenovo T431s.

General Steps

  1. mkdir -p /etc/X11/xorg.conf.d
  2. Create a file, touchpad.conf in above dir.

    Section "InputClass"
        Identifier      "Touchpad"                      # required
        MatchIsTouchpad "on"                            # required
        Driver          "synaptics"                     # required
        Option          "MinSpeed"              "0.5"
        Option          "MaxSpeed"              "1.0"
        Option          "AccelFactor"           "0.075"
        Option          "TapButton1"            "1"     # left click with one finger tap
        Option          "TapButton2"            "3"     # right click with two finger tap
        Option          "TapButton3"            "2"     # middle click with three finger tap
        Option          "VertTwoFingerScroll"   "1"     # two finger vert scroll
        Option          "HorizTwoFingerScroll"  "1"     # two finger horz scroll
        Option          "MaxTapTime"            "250" # alter this to get good multifinger tap recognition, this is what worked well for me
        Option          "FastTaps"              "1"
        Option          "HorizEdgeScroll"       "1"
        Option          "PalmDetect"            "1" # detects palm touches while typing
    EndSection
    

    Additional customizations to the synaptic driver can be found in the man page.

  3. Using dconf-editor uncheck "active" in org > gnome > settings-daemon > mouse.

The above should get two finger scrolling, multfinger clicks and everything else working well. To disable the touchpad while typing you can use syndaemon -i 0.5 -d.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.