Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I was poking around the flashplugin of Adobe for Linux trying to get the Hardware Acceleration working (which my current configuration supports). Then I found several forums/blogs that recommend I create/modify some or other value in the /etc/adobe/mms.cfg, which didn't help at all for my current situation.

This leads me to think, does the Flash non-free plugin of Adobe for Linux read this file for configuration? Is there another way to modify Flash configuration without the traditional GUI's (flash-player-properties doesn't help in the HWA topic and I am already tired of ticking the box Right-click -> Settings -> Enable Hardware Acceleration)?

I'm using Iceweasel 24.0a2, Debian Wheezy 7.0, Shockwave Flash 11.2 r202 11,2,202,297.

$ glxinfo | grep render
direct rendering: Yes
OpenGL renderer string: Gallium 0.4 on ATI RV515
share|improve this question
add comment

1 Answer

up vote 3 down vote accepted

These settings are found in settings.sol, buried deep in the profile directory ~/.macromedia/ The problem is that this file is a hex file. I got a sol editor off the internet, but only works on windows.

When I had to turn off Hardware Acceleration, I had to check the safefullscreen setting in the sol editor. It disabled hardware acceleration. I think that if you unselect it it will enable the Hardware acceleration again.

share|improve this answer
    
I would love a native linux editor. But indeed the file is there, just that I can't read it since all editors are made for windows (and wine is not an option). –  Braiam Jul 12 '13 at 22:55
    
I completely I looked for a while and although there are hex editors for Linux there are no sol editors –  Eric Jul 13 '13 at 2:08
    
If you manually set the .sol file once you could write a profile.d script to copy it to,the right location if it isn't the right one that's what I,did at work –  Eric Jul 13 '13 at 2:10
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.