Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm facing a problem with ABD connection under Kubuntu 13.04 x64. Every time I try to push/pull/shell ls the adb disconnects from device. I tried the following solutions:

  1. Added device ID into .android/adb_usb.ini but nothing helped
  2. Added new udev rule and also nothing helped
  3. Flashed the ROM and nothing helped
  4. I re-installed my Kubuntu 13.04 x64

Some notes :

  • USB Debugging activated
  • Device is Prestigio PMP5080BRU (Rooted) - Android Gingerbread 2.3.1
  • I'm using the latest Android SDK available on official web site
  • The ADB works very well on Windows 7 x64
  • Even when ADB disconnects, I still can see device via lsusb command
  • ia32-libs already installed on the system
  • jdk and jre installed on the system and works as expected
  • Paths configured and working properly
  • ADB works as expected with my Samsung Galaxy S II (Jelly Bean 4.1.2 - Stock)
  • I put my question here, because it seems I got a problem in Linux, as my other device works on Kubuntu

dmesg :

[ 5571.640498] usb 3-2: new high-speed USB device number 13 using xhci_hcd
[ 5571.657013] usb 3-2: config 1 interface 1 altsetting 0 bulk endpoint 0x83 has invalid maxpacket 64
[ 5571.657426] usb 3-2: New USB device found, idVendor=0bb4, idProduct=0c02
[ 5571.657433] usb 3-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 5571.657436] usb 3-2: Product: rk2918
[ 5571.657439] usb 3-2: Manufacturer: RockChip
[ 5571.657442] usb 3-2: SerialNumber: 0123456789ABCDEF
[ 5571.664067] scsi13 : usb-storage 3-2:1.0
[ 5572.659163] scsi 13:0:0:0: Direct-Access     PMP5080B                  0100 PQ: 0 ANSI: 2
[ 5572.659453] scsi 13:0:0:1: Direct-Access     PMP5080B                  0100 PQ: 0 ANSI: 2
[ 5572.661211] sd 13:0:0:0: Attached scsi generic sg2 type 0
[ 5572.661525] sd 13:0:0:1: Attached scsi generic sg3 type 0
[ 5572.662492] sd 13:0:0:0: [sdb] Attached SCSI removable disk
[ 5572.662947] sd 13:0:0:1: [sdc] Attached SCSI removable disk

Any one got an idea? Regards,,,

share|improve this question
    
What does modinfo rk2918 show? –  Nils Jul 11 '13 at 21:41
    
ERROR: Module rk2918 not found. –  WindGhost Jul 12 '13 at 7:48
    
What is the Product, if you connect your S II? Can you do a modinfo on that? –  Nils Jul 12 '13 at 14:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.