Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm in the process of trying to configure TOR on a Kali installation, as a system-wide SOCKS proxy. I just did this successfully on Ubuntu, and it worked like a charm. I installed TOR & Vidalia from the Debian repositories, started the TOR service using service tor start, and checked to see that my computer was listening on the default port, 9050, for SOCKS connections to be routed through the TOR service; which it was. Vidalia tells me I'm connected to the TOR network.

The problem is the Network -> Proxy section of the settings manager in Kali. I can enter in the necessary information to connect to the local SOCKS proxy, but there is no 'apply' button or anything to that effect. I have entered the information, hit enter, exited out (and when I go back, it is still there) of the settings manager, restarted the networking service, etc., but I have not been able to get the proxy settings to take effect. This worked beautifully in Ubuntu, I entered the SOCKS settings in the settings manager and hit 'apply', and all traffic was being routed through the TOR network. Any ideas?

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.