Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am trying to setup real vnc server on my RHEL via command line.

I have done the following steps

  1. Downloaded the Real VNC installer from Real VNC for Red Hat 64 bit system
  2. Unizipped it to get to rpms VNC-Server-5.0.5-Linux-x64.rpm,VNC-Viewer-5.0.5-Linux-x64.rpm
  3. The documentation did not have any command line installation instructions
  4. Followed the instructions given in this forum
  5. rpm VNC-Server-5.0.5-Linux-x64.rpm -i
  6. vnclicense -add <KEY>
  7. netstat -an | more

    tcp        0      0 0.0.0.0:5901                0.0.0.0:*                   LISTEN
    tcp        0      0 0.0.0.0:5902                0.0.0.0:*                   LISTEN
    tcp        0      0 0.0.0.0:5903                0.0.0.0:*                   LISTEN
    
  8. On windows 7 I installed RealVNC Viewer and tried connecting to the server, I get an error promt connect: Connection refused (10061)

share|improve this question

1 Answer 1

up vote 1 down vote accepted

You need to start vnc session from your Linux account to be able to connect to your session, run vncserver from your command line of your Linux system. After you issue this command it will tell you your session ID to connect. Here is an example:

         [root@systemname]# vncserver

         New 'systemname:1 (username)' desktop is systemname:1

         Starting applications specified in /username/.vnc/xstartup
         Log file is /username/.vnc/servername:1.log

If the above task is already covered then you may need to make sure that firewall on your Linux side as well as windows side is disabled for specified port 5901 or 5902.., related to the connection ID that you are trying to connect. if you are using SELinux then you need to make sure that is also configured to allow your VNC session.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.