Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am new to linux. I just installed fedora 19 and it shows that i am not connected to network (not recognizing network) though my connections are correct.
I don't know what to do. Can any one please help me (please..)?

The network is wired.

The result of ifconfig

lo : flags = 73 < UP,LOOPBACK,RUNNING > mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10
loop txqueuelen 0 (local loopback)
RX packets 640 bytes 55680
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 640 bytes 55680
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

wlp3so : flags = 4099< UP,LOOPBACK,RUNNING > mtu 1500
ether 9c:4e:36:96:ae:30 txqueuelen 1000 (ETHERNET)
RX packets 0 bytes 0
RX errors 0 dropped 0 overruns 0 frame 0

Result of any ping ip address gives the following results

connect : network is unreachable

share|improve this question
    
Welcome to Unix.StackExchange.com. This post does not provide enough informations to solve your problem. Please figure out the network technologies of your ethernet card and your router etc and provide output of ifconfig and so on. -1 for so few informations. –  superuser0 Jul 5 '13 at 18:59

3 Answers 3

This is a very open ended question. You need to include what you have already tried as well as more information on how you're connected. Is this wired or wireless? Can you ping IP addresses but not hosts? There are a lot of questions that need to be answered.

I will try to give you some basic "how to" information here.

First, open a terminal and type ifconfig. Look for your listed network device there and ensure there is actually a connection. This command can give you lots of information on possible problems.

If connection looks good there, we need to diagnose why fedora thinks your not connected. First things first, try to ping just an IP address locally. Your routers IP address works great here.

If you can ping your router then try to ping outside your network. IP 8.8.8.8 is one of google's public dns servers and it responds to pings. Go ahead and ping that. If you get a response there then the problem is with your hostname resolution, in which case you need to put your nameservers in the /etc/resolv.conf file.

If you are unable to ping out but can ping locally, check your default gateway setting. In Fedora that setting is in /etc/sysconfig/network

If you can not ping locally, check your ip address and netmask setttings.

Do some of these research items and edit your question when you have more detailed information please.

share|improve this answer

While I don't have an answer to this question, I am experiencing a similar issue (despite having used Fedora for several release cycles now). The same machine had no issues with FC 18.

No internet whatsoever, and I cannot ping globally in or out; local ping works, however. Gateway appears to be correct (it's identical to a machine with FC 16 sitting right next to it), except for the brand-new device names.

$ ifconfig
ens33: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 130.39.99.131  netmask 255.255.252.0  broadcast 130.39.99.255
        inet6 2620:105:b000:7100:ca60:ff:fec9:a6ff  prefixlen 64  scopeid 0x0<global>
        inet6 fe80::ca60:ff:fec9:a6ff  prefixlen 64  scopeid 0x20<link>
        ether c8:60:00:c9:a6:ff  txqueuelen 1000  (Ethernet)
        RX packets 38968  bytes 7191891 (6.8 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 428  bytes 38829 (37.9 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 0  (Local Loopback)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

$ route -nee
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface    MSS   Window irtt
0.0.0.0         130.39.96.1     0.0.0.0         UG    0      0        0 ens33    0     0      0
130.39.96.0     0.0.0.0         255.255.252.0   U     1      0        0 ens33    0     0      0
share|improve this answer
up vote 0 down vote accepted

I found out that the error is due to atheros AR8161 driver. So i have to install them.
Installing them with internet connection is easy,
but i dont have any wired(because it is not getting recognised) and any wireless network.
Can someone help me with this?

share|improve this answer
    
Done using usb dongle –  user2545889 11 hours ago

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.