Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have extremely slow wifi connection on my linux mint. The network controller is Intel Corporation Centrino Advanced-N 6235 (rev 24). I found on the ubuntu wiki a fix:

sudo rmmod iwlwifi && sudo modprobe iwlwifi 11n_disable=1

I got:

Error: Module iwlwifi is in use by: iwldvm

So I did:

sudo rmmod iwldvm, sudo rmmod iwldvm (went fine then) and sudo modprobe iwlwifi 11n_disable=1

My wlan0 was not up, so I started the iwldvm too.

sudo modprobe iwldvm

Unfortunately the internet is still too slow. I tried different approaches but nothing worked. Mainly I am confused that the wifi worked fine for a week, now I am experiencing such troubles. I've read that the kernel upgrade to 3.10 should fix this, but I can't boot that one and 3.9 didn't fix this.

Is it possible that my machine (asus zenbook prime) is using different thing then the iwlwifi? I am just asking because I found a file in /etc/modprobe.d/ called iwlwifi.conf which contains:

# /etc/modprobe.d/iwlwifi.conf
# iwlwifi will dyamically load either iwldvm or iwlmvm depending on the
# microcode file installed on the system.  When removing iwlwifi, first
# remove the iwl?vm module and then iwlwifi.
remove iwlwifi \
(/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) \
&& /sbin/modprobe -r mac80211

The lsmod | grep iwlwifi command gives me:

iwlwifi               173477  1 iwldvm
cfg80211              510937  3 iwlwifi,mac80211,iwldvm
share|improve this question
    
btw I can fix this changing the wireless mode to 802.11n, but otherwise it's slow... –  tsusanka Jul 4 '13 at 10:33
    
I have the same laptop, running Ubuntu 12.04. Do you experience frequent loss of connectivity for about 30s at a time on certain 802.11n connections? –  Thucydides411 Sep 5 '13 at 15:54
    
You mean being disconnect from wifi hotspot? No the connection is stable, but the speed is very various. If u meant something else, let me know how can i provide better info –  tsusanka Sep 7 '13 at 9:57
    
No, Ubuntu reports that I'm still connected, but /var/log/kern.log reports every few minutes that it's reauthenticating and reassociating. During this time, connectivity is lost. –  Thucydides411 Sep 7 '13 at 14:35
add comment

1 Answer

I took the iwlwifi driver-6000g2b-ucode-18.168.6.1.tgz from here http://wireless.kernel.org/en/users/Drivers/iwlwifi now everything works fast

share|improve this answer
    
Welcome to Unix & Linux Stack Exchange! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  slm Feb 9 at 13:18
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.