Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I used suspend (to ram) for a long time, and it worked flawlessly. Recently, I started using hibernate (to disk) - not-quite-flawlessly. Hibernate-to-disk works (from the terminal, so far - as pm-hibernate), and resume almost works. I see messages about reading/restoring the hibernation image, but then the 'hibernation console' (not sure if that's the right term) just sits there, and seems to ignore all normal input.

'Sys-Rq magic' gets me past this (I kill all tasks, which gets me out of the 'hibernation console', and then resume finishes), but I'd like to know what's going wrong.

I've tried looking through the logs in /var/log/, but haven't seen anything notable (although it's certainly possible that I missed something).

I'm using (K)Ubuntu 12.04, kernel 3.2.0-38-generic. I have 2GB of RAM and 4GB of swap.



Note: This is very similar to a previous question of mine. @Gilles pointed me to the right Sys-Rq 'magic' combo, which gets me around the problem (Thanks!). That doesn't really answer why this is happening, though. So, now I'd like to get at the underlying problem (both out of curiosity, and to narrow down causes to some other problems). Old question:

Resume from hibernate fails after image restoration

Edit: As I mentioned in my previous question about this problem, this (unanswered) forum post describes a situation that sounds almost the same. The guy there is using Mint, and says he has seen this in Debian-derived distros, but not in others. http://forum.linuxmint.com/viewtopic.php?p=708058&sid=e8bd8eba8fad0b25597209e365d6edf4

share|improve this question
    
@Gilles, I think you said you had the same problem. If your specs are different (kernel version, DE?), would you post them? Thanks. –  hunter2 Jul 4 '13 at 10:41
    
Ubuntu 12.04, I don't remember the exact kernel versions where I observed the problem (kernel-3.2.0-$n-generic, currently $n = 48 but I haven't hibernated since my last reboot). I run sudo pm-hibernate from an X11 console. –  Gilles Jul 4 '13 at 11:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.