Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am using Linux Mint 10, and it is installed on sda8.

I edited /etc/grub.d/40_custom:

#!/bin/sh
echo "Adding 40_custom.">&2
exec tail -n +3 $0
# This file provides an easy way to add custom menu entries. Simply type the
# menu entries you want to add after this comment. Be careful not to change
# the 'exec tail' line above.

menuentry "fedora ISO" {
    loopback loop (hd0,8)/boot/iso/Fedora-14-i386-DVD.iso
    linux  (loop)/isolinux/vmlinuz boot=isolinux iso-scan/filename=/boot/iso/Fedora$
    initrd (loop)/isolinux/initrd.img
}

Then I ran sudo update-grub2. After rebooting, I chose “Fedora ISO”. The computer restarted.

I tried following this guide, but it didn't help.

Do I need to change the file permissions of the boot and casper folders or there is some other problem?

share|improve this question
    
Related: Installing Grub (2) on a USB flash drive –  phunehehe Feb 25 '11 at 14:28
add comment

2 Answers

You have to make sure that the lines point to correct file locations. For example, I have a Fedora ISO with me, but I cannot find the file /boot/vmlinuz or /boot/initrd.img in it. At the very least you should have:

menuentry "Fedora ISO" {
    loopback loop (hd0,8)/path/to/Fedora-14-i386-DVD.iso
    linux (loop)/isolinux/vmlinuz0 boot=isolinux iso-scan/filename=/Fedora13.iso splash --
    initrd (loop)/isolinux/initrd0.img
}

Maybe you misunderstood that, but linux and initrd above point to the entries inside the ISO, not on your hard drive.

share|improve this answer
    
phunehehe,i have changed the code as u said still when i choose fedora Iso at grub,the pc restarts –  user4391 Feb 25 '11 at 14:53
add comment

I tried Grub2 to boot directly to a .iso`` file with Fedora, CentOS live CD but failed. I think it is because they are using the CD's label to detect the root device. I have extracted Fedora's ISO content to a folder and hook it with this:

menuentry "Fedora 16 [GNOME] (x86_64)" --class fedora --class os {
  linux /boot/iso/Fedora-16-x86_64-Live-GNOME/isolinux/vmlinuz0 root=UUID=DB92-7E14 rootfstype=vfat ro liveimg quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0
  initrd /boot/iso/Fedora-16-x86_64-Live-GNOME/isolinux/initrd0.img
}

You can find your boot partition UUID by using this command line:

ls -lh /dev/disk/by-uuid/

Remember to change your boot partition type to your.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.