Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have this odd problem where whenever a link is opened from the shell, the cached html is opened locally, instead of through a browser.

to illustrate:

if I run the command xdg-open http://www.google.com in a bash prompt, this url opens in my browser bar: file:///var/tmp/kdecache-seldon/krun/13954_0_.

Here is an image of how it loads in chromium (which is currently set as my default browser).

weird error.


This issue also happens when there is a call to open a link from (most) applications, for instance, clicking on an external link in the help documentation for Gwenview.

Does anyone have any insight as to why this might be happening? Anything I can try to keep this from happening?


Updating with some steps that I have tried:

  • launching a url with the application path works just fine (i.e. chromium-browser http://www.google.com or firefox http://www.google.com

  • I checked ~/.local/share/applications/mimeapps.list and thought I had actaully found the problem because text/html was pointed to an old, non-existent .desktop file. But fixing the entry to chromium-browser.desktop did not fix the problem

I am still at a loss for what this issue could be

share|improve this question
    
this is a known bug. Check if any of the solutions posted in the bug tracker works for you. –  dcmst Jul 1 '13 at 9:54

1 Answer 1

Im not entirely sure what goes on behind the scenes in KDE but it appears that chrome was not getting the url as a parameter, it was getting the fetched html instead (and only the html, no other resources).

So based on this answer for getting web based email as your default in KDE, on a hunch, I added $s to the end of the default Web Browser component, and it worked. I would love to know more about the $s parameter, if anyone knows, but it fixed this specific issue.

to fix this issue: In System Settings, under Default Applications for Web Browser, I changed /usr/bin/chromium-browser to /usr/bin/chromium-browser $s

(obviously /usr/bin/chromium-browser should be changed to the path of whichever browser you use)

share|improve this answer
    
+1 Thanks - this also worked for me. –  Will Dec 4 '13 at 9:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.