Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

As the title says, I recently ran the system updater. At the time there was 400 updates. I installed them all and everything was peachy.

A few days later it showed that I had more updates. So, wanting to avoid getting to 400 updates again, I ran them. There was only 4 and they were all related to python libs.

These were all level 3 updates and I installed them the day after they came out (6/25/13).

I am a Ruby On Rails developer and the next day I came in and was working on a project, I went to run my rails server with the command rails s and I got this message:

rails is not currently installed please run apt-get install rails to install.

I then tried to run rake, cap -f deploy(capistrano), and even ruby -v and I got the same message for all of them.

RubyMine (my IDE) still sees that ruby on rails is installed, and I can run my dev server though that.This is not ideal however so:
How do I make my terminal see my ruby on rails installation again?

share|improve this question
    
possible duplicate of How to install Ruby 1.9.3 on Arch? –  jasonwryan Jul 1 '13 at 20:07
    
@jasonwryan this is def not a duplicate. I don't have rvm installed and I don't need to manage multiple versions of ruby. For some reason my terminal isn't pointing to the correct version but my IDE is. I am trying to figure out how to get my terminal to point to the right version. Not download a version manager. I don't even want the old version and I don't know where it came from... –  ryan Jul 2 '13 at 14:08
    
"Getting your terminal to point at the right version" sounds a lot like needing a version manager to me... –  jasonwryan Jul 2 '13 at 20:02
    
@jasonwryan read the rest of what I wrote. I don't want a version control manager because I don't want multiple versions! I want the one version that's been working for the last year till now. But when I uninstall the bad version that was installed when I ran the apt-get install cap command, it doesn't revert to using the correct version of ruby, it just says that no version of ruby is installed at all! There is a reason the question is long. Context matters. As far as my terminal is concerned the version of ruby I need and know is installed doesn't exist on the computer... –  ryan Jul 2 '13 at 20:29
    
I can read. I also have some experience with ruby and managing various versions. ALL of the symptoms you describe point to versioning issues; the recommended way to deal with that is a version manager. In any event, you don't seem to want my help, so I'll leave you to it... –  jasonwryan Jul 2 '13 at 20:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.