Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have a Gigabyte Q2532 laptop and Enable Wi-Fi of NetworkManager is not selectable. As for the device, here is the relevant entry from lspci:

03:00.0 Network controller: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) (rev 01)

I can see the driver is loaded:

$ lsmod | grep ath
ath9k                  83980  0 
ath9k_common           12728  1 ath9k
ath9k_hw              345710  2 ath9k_common,ath9k
ath                    21417  3 ath9k_common,ath9k,ath9k_hw
mac80211              386825  1 ath9k
cfg80211              366201  3 ath,ath9k,mac80211

I also installed the firmware package, firmware-atheros, but I still get the same issue.

Manually loading the driver gives me this on /var/log/syslog:

Jun 27 22:36:53 thome kernel: [ 5758.818796] ath: phy1: ASPM enabled: 0x42
Jun 27 22:36:53 thome kernel: [ 5758.818799] ath: EEPROM regdomain: 0x60
Jun 27 22:36:53 thome kernel: [ 5758.818801] ath: EEPROM indicates we should expect a direct regpair map
Jun 27 22:36:53 thome kernel: [ 5758.818803] ath: Country alpha2 being used: 00
Jun 27 22:36:53 thome kernel: [ 5758.818803] ath: Regpair used: 0x60
Jun 27 22:36:53 thome kernel: [ 5758.820362] ieee80211 phy1: Selected rate control algorithm 'ath9k_rate_control'
Jun 27 22:36:53 thome kernel: [ 5758.820686] ieee80211 phy1: Atheros AR9285 Rev:2 mem=0xffffc90004ec0000, irq=17
Jun 27 22:36:53 thome NetworkManager[1004]: <info> rfkill3: found WiFi radio killswitch (at /sys/devices/pci0000:00/0000:00:1c.1/0000:03:00.0/ieee80211/phy1/rfkill3) (driver ath9k)
Jun 27 22:36:53 thome NetworkManager[1004]: <info> WiFi now disabled by radio killswitch
Jun 27 22:36:53 thome NetworkManager[1004]: <info> (wlan0): using nl80211 for WiFi device control
Jun 27 22:36:53 thome NetworkManager[1004]: <info> (wlan0): driver supports Access Point (AP) mode
Jun 27 22:36:53 thome NetworkManager[1004]: <info> (wlan0): new 802.11 WiFi device (driver: 'ath9k' ifindex: 7)
Jun 27 22:36:53 thome NetworkManager[1004]: <info> (wlan0): exported as /org/freedesktop/NetworkManager/Devices/4
Jun 27 22:36:53 thome NetworkManager[1004]: <info> (wlan0): device state change: unmanaged -> unavailable (reason 'managed') [10 20 2]
Jun 27 22:36:53 thome NetworkManager[1004]: <info> (wlan0): bringing up device.
Jun 27 22:36:53 thome NetworkManager[1004]: <info> (wlan0): deactivating device (reason 'managed') [2]
Jun 27 22:36:53 thome NetworkManager[1004]:    SCPlugin-Ifupdown: devices added (path: /sys/devices/pci0000:00/0000:00:1c.1/0000:03:00.0/net/wlan0, iface: wlan0)
Jun 27 22:36:53 thome NetworkManager[1004]:    SCPlugin-Ifupdown: device added (path: /sys/devices/pci0000:00/0000:00:1c.1/0000:03:00.0/net/wlan0, iface: wlan0): no ifupdown configuration found.

NetworkManager config file:

$ cat /etc/NetworkManager/NetworkManager.conf 
[main]
plugins=ifupdown,keyfile

[ifupdown]
managed=false

The other config file:

$ cat /etc/network/interfaces
auto lo
iface lo inet loopback

NetworkManager is at 0.9.8.0, and...

$ uname --all
Linux thome 3.11-rc4-amd64 #1 SMP Debian 3.11~rc4-1~exp1 (2013-08-08) x86_64 GNU/Linux

It didn't work with Linux versions 3.9 and 3.10 as well.

Also:

$ iwconfig wlan0 
wlan0     IEEE 802.11bgn  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=off   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
share|improve this question
    
Take a look at this Q on askubuntu: How to let NetworkManager manage WLAN interface after upgrade? –  slm Jun 28 '13 at 3:19
    
Purging and reinstalling did not help. Thanks though. –  Tshepang Jun 28 '13 at 6:18
    
What distro is this? –  slm Jun 28 '13 at 6:20
    
This is Debian Jessie (testing). –  Tshepang Jun 28 '13 at 6:46
1  
Can you set it up manually w/o network manager: ubuntuforums.org/showthread.php?t=571188 –  slm Aug 31 '13 at 3:39

2 Answers 2

up vote 1 down vote accepted

Thanks to @JosephR for pointing to this post, which alerted me to the idea that I did not press the right buttons. There is a Fn key combination that actually enables Wi-Fi... I do feel stupid, given I been frustrated by this issue for months now.

share|improve this answer
1  
This should be a sanity check comparable to the immortal "Is it plugged in?" :D I once spent hours installing and re-installing a wireless driver only to find out that I had the wireless hardware button set on disable. –  Joseph R. Sep 1 '13 at 15:17
1  
This is one of those cases where one needs a second pair of eyes. –  Tshepang Sep 1 '13 at 15:54

Are you trying to use the Network Manager applet? It can frequently 'freeze'. I'd killall nm-applet, start nm-applet again and see if it is fine then.

share|improve this answer
    
I think this is ruled out because trying wicd failed. See the OP's comment on the question. –  Joseph R. Aug 31 '13 at 23:13
    
What does freeze mean? Other than the fact that the WiFi button is not selectable, the applet is fully functional. –  Tshepang Aug 31 '13 at 23:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.